LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-09-2002, 03:28 PM   #1
magyartoth
Member
 
Registered: Feb 2002
Location: Pittsburgh, PA, USA
Posts: 73

Rep: Reputation: 15
bash shell not working?


Here's a strange one.

Just installed a new email server running Red hat 7.2. I installed SSH and I can remotely SSH to the box fine, login and stuff, but a lot of the usual bash commands that Im used to are gone.

For example, useradd, userdel, usermod, route, fsck, as well as some others, are all missing.

I have my shell set as bash which is installed and working. When I log in, I don't get a 'missing shell' error, I just get the familiar bash prompt. Even when I 'su', I still can't use these commands.

HOWEVER, when I login locally as root, all the commands are there using bash.

Any thoughts? I'm stumped!
 
Old 04-09-2002, 03:32 PM   #2
jpweston
Member
 
Registered: Mar 2002
Location: Sacramento, CA
Distribution: Slackware 8.1; Debian 3.0
Posts: 222

Rep: Reputation: 30
Is there a separate profile for ssh/remote logins? If so, there may be some restrictions in there. Maybe check the startup sequence for SSH and see what it's reading for its configuration.

j.
 
Old 04-09-2002, 04:04 PM   #3
magyartoth
Member
 
Registered: Feb 2002
Location: Pittsburgh, PA, USA
Posts: 73

Original Poster
Rep: Reputation: 15
I installed SSH as an RPM when I installed everything else and left all the defaults in place. I checked sshd_config and couldn't find anything about paths.

I've noticed that when I do an env $PATH when remotely connected with SSH, that my path is really short(/bin:/usr/bin:/usr/local/bin), however it's a lot longer when locally connected with root.

Anyway of setting a general $PATH varible?

Thanx
 
Old 04-09-2002, 07:21 PM   #4
jpweston
Member
 
Registered: Mar 2002
Location: Sacramento, CA
Distribution: Slackware 8.1; Debian 3.0
Posts: 222

Rep: Reputation: 30
You can set the PATH for a single session by doing

export PATH=$PATH:/whatever/you/want

To make it "sticky" for all future sessions it needs to be read from a config or profile file (i.e. for users that can be ~/.bash_profile or ~/.bashrc - the global profile is /etc/profile). That's why I'm thinking there is a similar file for ssh/remote logins - even though you're logging in as an existing user.

Here's a link I found on Red Hat's site for SSH - see if this helps:

http://www.redhat.com/docs/manuals/l...nfigfiles.html

j.
 
Old 04-09-2002, 09:56 PM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Instead of 'su' try 'su -'. There's a space between the 'u' and the '-'.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lowercase 'b' not working in bash shell BWebb Linux - Software 1 05-17-2005 05:24 PM
Bash Shell Startup Files - Not working! Carl-Fredrik Linux From Scratch 1 10-20-2004 04:52 PM
What is Bash shell? xailer Linux - Newbie 4 11-23-2003 10:29 AM
bash shell dawood shaheen Programming 9 08-01-2003 06:07 AM
Help!!!!! Bash Shell???? DarkHorse Linux - Newbie 7 06-04-2001 01:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration