LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   Baffling reboot/shutdown issue... (https://www.linuxquestions.org/questions/linux-general-1/baffling-reboot-shutdown-issue-52434/)

tisource 03-29-2003 09:50 PM

Baffling reboot/shutdown issue...
 
I've searched this forum several times, and cannot seem to find an answer.

Using Mandrake 8.2,9 and 9.1 my machine will freeze when I reboot or shutdown (8.1 doesn't freeze). It tries to reboot and hangs half way. I have to power the machine off completely to get it to boot again.

The wierd thing is that this problem occurs in RedHat 7.3 and older, but not with version 8. The problem is that I'm no fan of RedHat (it's just not my preference).

I am baffled as to what is causing the problem. I've tried shutting down as many things as I can before I shutdown, but it doesn't seem to help.

If any of you have any ideas, I'm more than happy to hear them. I really want to get Mandrake 9.1 working right, if I can.

My system is:
Compaq Presario 1210us notebook
850 MHz AMD Duron
320MB PC133 Ram
20 GB HD/ATI Rage Mobility M-1 8MB AGP

mcleodnine 03-29-2003 11:04 PM

Where exactly does it stop during the halt process? ie: on what process does it stop.

tisource 03-30-2003 12:38 AM

It completes the shutdown of services, and gets half way through a reboot. My "COMPAQ" bios screen pops up, and I get a solid white cursor at the top-right corner. It's freezing during post, as I can tell. That is what is so strange. I don't know if it is a memory thing, or what. It won't halt, won't reboot. I have to power it off ("Pull the plug") to get it to respond.

This problem has occured since Mandrake 8.2, and older versions of redhat (previous to version 8). I don't know enough about it to solve the problem, if it can be solved. Mandrake 8.1 worked pretty good in terms of rebooting/locking up.

Redhat 8 does do the same thing after setup completes, but doesn't when you boot the os and restart. I'm just not sure what to do about it.

Any ideas?

moses 03-30-2003 10:05 AM

You say it will freeze when you "reboot or shutdown". Does this
mean it will also freeze at the same point after you've shutdown,
powered off, and powered it back up? I suspect not, but need to
be sure. It sounds like a piece of your hardware is being left in
an undefined state after you unload linux. This is *probably* a
hardware problem (because it happens for more than one distro).
Try setting linux so that it doesn't load drivers for a piece of
hardware (sound card, for example), reboot, boot linux, then
reboot to see if it freezes. Repeat until you find the problem. It
could be a necessary piece of hardware, but you say it doesn't
happen for some versions, which means either a nonessential
(RAM, CPU, etc.) piece of hardware, or a driver does something
different. Anyway, you should be able to figure out which piece
of hardware is affected.

tisource 03-30-2003 10:27 AM

Once the machine is powered down, it fires back up, the bios gives me a "your previous boot was imcomplete...do you want to continue or enter setup". I continue and everything boots just fine.

Once I go to reboot again, it does the same thing.

How to I disable devices/unload drivers? I see what you mean, but I have no idea how to do that.

moses 03-30-2003 02:50 PM

Well, I *think* the start up scripts are in /etc/init.d for Mandrake,
but someone with more knowledge of MDK's boot process should
confirm or correct this (it may be /etc/rc.3, for example).
In that directory (wherever it happens to be), you'll see a bunch
of scripts that start various services and devices.
I would do:
Code:

grep modprobe *
while sitting in that directory. This will show which scripts load
up device drivers. Edit those scripts and comment out all the
modprobe lines, except one. Reboot and reload linux, then
reboot and see if that fixed it. repeat.
There is probably some MDK GUI that allows one to disable
certain devices, and that may be easier to deal with, but I don't
know what that tool is (I really should install Mandrake some day
and mess with it).

mcleodnine 03-30-2003 03:14 PM

This looks more like a Comapq-specific issue. If you're seeing the large flashing cursor that's the Compaq boot loader, which will load the maintenance/setup software if you press F10 while the cursor is visible. The software usually lives in a small (usually 2 - 10 MB, depending on your version/platform) partition at the end of your hard drive. If you don't have that partition anymore you can still get a floppy that can do the job as well. Run the diagnostics and setup and see if you can get any extra info as to what's happening. Specifically I'd look at the power management and PnP settings.

tisource 03-31-2003 12:32 AM

I don't think this is compaq specific, and the reason I don't is that I've heard of other notebook vendors having the same problem. I think it is a driver. There is no compaq boot loader (I use XOSL to boot, and put lilo in the / partition instead). The error screen I'm referring to is a bios prompt, nothing more. One key boots, the other key takes me to BIOS setup.

I don't have options in the BIOS setup. I have no way to control PnP or power management. I can set boot order, change the system clock, and set a boot password. That's it. It's a phoenix bios....need a say more?

I will try the modprobe stuff, see what it gives me. For the moment, I'm going to study my calculus test.

Thanks a bunch for the help. I'll let you guys know how the modprobe stuff goes.

snocked 03-31-2003 01:00 AM

Same thing happened to me with Slackware 8.1 and 9, but no problems in SuSE, Mandrake, Red Hat, XP, etc.

natedawg_38929 03-31-2003 12:01 PM

Make sure that your APM (Auto Power Management) module is loaded, because if not, those same symptoms will occur.

tisource 03-31-2003 03:07 PM

Well, I can halt okay....I just can't reboot.

I was going to try disabling devices and seeing if that helps, but it is more complex than I anticipated. Isn't there a command that I can use to disable or enable devices from starting? Redhat has a chkconfig command they use for services (dhcp, etc) and gentoo (I am told) has a rc-update command. Is there something like that I can use?

As far as apm is concerned, I've never used it before, and prior to Mandrake 8.1, I haven't had a problem. It is worth a try, though. How do I do that? It should be in my list of services in mandrake control panel, right? Does Mandrake install that by default, and is it just called apm? Or is the package named something else?

bahamat 03-31-2003 03:28 PM

This also happens on my laptop, it's probably a "feature" of the lovely phoenix bios we're both using.

I've avoided this situation by never issuing a reboot. Always shut it down and press the power on.

If it's remote and you can't be there to push the button then you probably shouldn't be shuting it down in the first place

tisource 03-31-2003 04:08 PM

I wouldn't call that a solution. The fact that it works on some distros and not others (at least to some extent) would lead lead me to assume that it isn't the bios.

Mandrake 8.1 and older does not do it...RH 8 and newer don't do it. There's something that is freezing it up. This machine in particular is a multiboot machine, and if I can't get it to multi-boot, I may have to go back to redhat (please no!).


All times are GMT -5. The time now is 11:03 PM.