LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-20-2003, 12:18 AM   #1
kgsum
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Rep: Reputation: 0
Question Backing up HD with Ghost


Hello,

I currently run a multi-boot system with Windows 98, XP, and Slackware 8.1. I use NT Loader initially, however when linux is selected LILO kicks in. This has been working perfectly for me for awhile so i decided to back everything up to a second hard drive using norton ghost 2003, so if anything happened i wouldnt have to re-install each OS.

I imaged my working drive to the backup drive, and then imaged it back to test it out. NT Loader seems to work ok (can boot into windows), however when i select linux and lilo starts, it freezes at "L" and loops "01 01 01 01 01 01" forcing me to reboot.

Both drives are 60GB, one is Quantum, the second is WD. Geometry wise, the Quantum is 7299/255/63, and the WD is 7297/255/63. I am assuming this is a problem with LILO not recognizing the drives geometry properly, but unfortunately I don't know a lot about this. I thought by copying the data sector for sector back to the drive it has been running off the whole time, linux should not see the difference in cylinders.

Does anyone have a suggestion on how to fix this? Or a better way I can backup my entire drive & bootsector?

Any help is greatly appreciated.

Thank you.
 
Old 02-20-2003, 08:05 AM   #2
vladkrack
Member
 
Registered: Oct 2002
Location: Curitiba - Brazil
Distribution: Conectiva
Posts: 334

Rep: Reputation: 30
Try to access your system with a boot disk, then mount your HD somehere, chroot this place then run lilo ...

Hope that helps ...
 
Old 02-20-2003, 09:36 AM   #3
kgsum
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I was able to boot off the slackware CD and mount /dev/hda5 (my root partition). When I try to run LILO, I get the error "Sorry, dont know how to handle device 0x0100".

I have no problem with wiping the drive and starting from scratch if need be. Since I am using NT Loader to boot all 3 OS's, can i just not install LILO at all when I install slackware? If I point NT Loader to my root linux partition, will that work?
 
Old 02-20-2003, 10:23 AM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,281

Rep: Reputation: 62
I think ghost changed your lilo config. just guessing

edit lilo back to what it should be then run lilo

make boot and root as hda5.

also maybe the results of what you did moved the
kernel or map file a little and your lilo boot sector
that you copied to the windows nt boot loader
is pointing to the wrong sector?

learn to use dd
its better for what you are trying to do with linux.
you can compress a partition like this
dd if=/dev/hda5 -|gzip -9 > /path/to/file.gz
 
Old 02-20-2003, 10:34 AM   #5
cli_man
Member
 
Registered: Apr 2002
Location: New York, USA
Distribution: Redhat 7.2, 9.0 Slackware 9.1
Posts: 428

Rep: Reputation: 30
What version of ghost are you using, this seems to be a popular problem you have to have ghost version 7.5 and above, what proably happened and I have seen this several times is it took ext3 filesystem and ghosted it as ext2, and it does not do that correctly so you pretty much have a corrupted linux file system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ghost software : Linux Ghost server NL-Stitch Linux - Newbie 18 02-02-2007 10:55 PM
Ghost alternative linuxmandrake Linux - Software 1 06-19-2005 08:12 PM
Ghost? kj6loh Linux - Software 3 04-26-2005 09:32 AM
Ghost and Linux robbow52 Linux - General 3 07-31-2004 01:24 AM
ghost lilo SCVirus Linux - Newbie 6 09-20-2003 09:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration