Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 12-03-2004, 04:39 AM   #1
LQ Newbie
Registered: Sep 2004
Posts: 21

Rep: Reputation: 15
Baaaah! GRUB suddenly doesn't allow graphical mode!

Ok, this is how it started.

I was overclocking my CPU (only a little) in the BIOS. I then loaded Windows (I have a dual boot system) and found that it wasn't working well. So I reduced the clock speed to its stock value. When I loaded Windows (XP Pro) again, I got a STOP error before Windows even started. I tried safe mode and it gave the same stop error.

So I loaded Linux to fix this problem. I loaded SUSE Linux 9.1 and started reading the Microsoft help pages, which suggested disabling shadowing and L2 cache to get into Windows. During this time Linux worked fine.

Then I went into my BIOS and disabled the L2 cache. But when GRUB was supposed to come, instead of the user-friendly graphical interface I was used to, the "BASH-like command line" opened up. At first I thought it was due to not having the L2 cache, so I enabled it again to see what GRUB would do. But GRUB still starts in command-prompt mode, and I have NO idea how to boot Linux & windows from it!

Question: How do I boot my Linux and windows partition from the bash-like GRUB? AND, how do I enable the graphical interface again?

I have an Intel Pentium 4, 256MB RAM, Windows XP Pro, and SUSE Linux Personal 9.1. My hardrive partitions are as follows...

hda1 - fat32 windows
hda2 - reiser linux
hda3 - linux swap
kernel 2.64-52
Old 12-07-2004, 10:11 PM   #2
Senior Member
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 1,995

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Grub should have a line or 2 in it like
title Your Linux Dist (2.6.4-52)

That is your graphical bootsplash immage.

Also if you can boot the machine and login in text mode
will start x and the default windows manager.
Old 12-08-2004, 04:36 PM   #3
Registered: Oct 2003
Location: Oslo, Norway
Distribution: RedHat 9.0, Fedora Core 1/2/3, Debian 3.0, Smoothwall
Posts: 110

Rep: Reputation: 15
I think teckk misunderstood.

It is probably BIOS-related trouble, but try this first at the grub-prompt:

root (hd0,0)

You may also use the TAB-button to show possibilities. Write root ( and then tab. You shld see some options, the disks on your system. Write f.ex. 1, and then tab again. You will now see all available partitions on disk 0 (hda). If your partition with the kernel-image is an hda1, write 0 and then press tab to get ) and enter.

Now, write kernel / and tab. You will see a list of files, the files on the partition you chose (grub is nice huh:d). Locate the correct image, and append the option root=/dev/hda2 before pressing enter.

Now write boot, enter (of course).

Post here to let me see how it works!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to; Suse9.3 prof. text mode to graphical mode anjum Linux - Software 5 07-20-2005 11:36 PM
Graphical mode grub? vharishankar Linux - General 2 04-05-2005 11:42 AM
how to get graphical mode back in grub ks_saru Linux - Software 1 02-02-2004 10:37 AM
Graphical Mode Hone101 Linux - Networking 3 03-21-2003 12:36 AM
Graphical mode to GUI Mode mikeshn Linux - General 5 04-10-2002 01:38 AM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 12:00 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration