LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-02-2003, 08:34 PM   #1
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Rep: Reputation: 30
Question ati drivers? - radeon 9100


hey guys, i have a radeon 9100, i would like to get it running properly under linux.

anyone else have this card, if so which drivers did you download from ati's website?

http://mirror.ati.com/support/driver.html

i know that this card is basically the same as the 8500, but with a new name!

oh yeah my card is the 64mb ddr version.

one more thing, what success levels (ie: performance) are people getting running unreal tournament 2003 in linux (the linux version)

cheers
 
Old 06-02-2003, 09:44 PM   #2
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
Don't let it confuse you, Ati offers one driver for all supported cards ...as in one size fits all, I mean there's different revisions and, at the link you posted, you'll get the last official release. They're almost 6 months old and probably wouldn't recognise the product ID of your newer card.
They also don't support XFree-4.3.0.

Anyway, your best bet, if you want the best performance in UT2003, get the glx1 for your XFree version here

Use the search for radeon 9x00, it'll provide some info on how to install them and different issues, as it's been discussed regularly in the last few months.
 
Old 06-02-2003, 11:15 PM   #3
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
<delete>

Last edited by fancypiper; 06-02-2003 at 11:17 PM.
 
Old 06-03-2003, 10:27 PM   #4
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by UnTamed
Anyway, your best bet, if you want the best performance in UT2003, get the glx1 for your XFree version
kool so lets see if i have got this right? i dont need to download any drivers from the ati site. just get the glx1 drivers you suggested? and ut2003 will be performing better?

cheers
 
Old 06-04-2003, 04:37 PM   #5
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
Yeah, that place mirrors Ati's newest drivers, think of it as "controlled leaks" approved by Ati.

Don't expect perf to be on par with M$ drivers just yet, but if you have a big CPU [...UT's graphic engines have always been CPU dependent] you could get decent perf outta them with no crash and very good IQ, just a little slow.
 
Old 06-04-2003, 06:15 PM   #6
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
cheers dude, one more question: is there an english version?

i have no i dea which driver suits my card (cant read language)

Kartentyp - i belive this is card type
Betriebs- no idea
-system - i can figure this and the next 2
Version
Filename
Beschreibung - no idea

also this is a lsiting from the card type field: Fire GL X1
Fire GL Z1
Fire GL E1
Fire GL 8800
Fire GL 8700

my card is a radeon 9100 (8500) how does this correspond to fire??

cheers for your help dude!
 
Old 06-04-2003, 08:12 PM   #7
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
The FireGL chip is now based on the Radeon core so we have a "unified" driver.
You can basically flash a 8500 to a FireGL8800 and I suspect the FireGL X1 and Z1 to be based on the r300 core ...but I haven't really checked.

...all that to say, as I said earlier, "get the glx1 for your XFree version", meaning if you still have Slack 8.1 and haven't upgraded XFree, get GLX1_LINUX_X4.2.zip, or else get either the X4.1 or X4.3 depending on your XFree version, it's that simple.

The only other option for linux is the GL2X series, which support the older FireGL, which were developped by ArtX before Ati bought them.
 
Old 06-04-2003, 08:36 PM   #8
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
ok i get the part about downloading the drivers now

but no i am confused about the fire stuff, only one confusion: do i have to flash my card?
 
Old 06-05-2003, 03:54 PM   #9
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
no you don't, that was just to emphasize how close both cards are, and explain why the same driver works on both kinds.
 
Old 06-06-2003, 10:45 PM   #10
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
ok kool, i downloaded the driver :glx1_linux_X4.3.zip
unzipped it , ran the file Check.sh and got this:

Code:
bash-2.05b# sh Check.sh
=====================================================================
 ATI Technologies 
=====================================================================
Checking which OS you're running...
uname reports 'Linux' version '2.4.20', architecture 'i686'.
Object format is 'ELF'.
libc version is '6.3'.

XFree86 Version 4.3.0 is installed.

No package available for glibc 2.3.  Try fglrx-glibc22-X43.tgz

bash-2.05b#
continued by truing to install the rpm that was unzipped, and got this :
Code:
bash-2.05b# rpm -Uhv fglrx-glc22-4.3.0-2.9.12.i586.rpm
error: failed dependencies:
        /bin/sh   is needed by fglrx-glc22-4.3.0-2.9.12
        /bin/sh   is needed by fglrx-glc22-4.3.0-2.9.12
        /bin/sh   is needed by fglrx-glc22-4.3.0-2.9.12
        /bin/sh   is needed by fglrx-glc22-4.3.0-2.9.12
        ld-linux.so.2   is needed by fglrx-glc22-4.3.0-2.9.12
        libc.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libdl.so.2   is needed by fglrx-glc22-4.3.0-2.9.12
        libICE.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libm.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libpthread.so.0   is needed by fglrx-glc22-4.3.0-2.9.12
        libSM.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libX11.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libXaw.so.7   is needed by fglrx-glc22-4.3.0-2.9.12
        libXext.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libXmu.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        libXpm.so.4   is needed by fglrx-glc22-4.3.0-2.9.12
        libXt.so.6   is needed by fglrx-glc22-4.3.0-2.9.12
        /bin/bash   is needed by fglrx-glc22-4.3.0-2.9.12
        libc.so.6(GLIBC_2.0)   is needed by fglrx-glc22-4.3.0-2.9.12
        libc.so.6(GLIBC_2.1)   is needed by fglrx-glc22-4.3.0-2.9.12
        libc.so.6(GLIBC_2.1.3)   is needed by fglrx-glc22-4.3.0-2.9.12
        libdl.so.2(GLIBC_2.0)   is needed by fglrx-glc22-4.3.0-2.9.12
        libdl.so.2(GLIBC_2.1)   is needed by fglrx-glc22-4.3.0-2.9.12
        libm.so.6(GLIBC_2.0)   is needed by fglrx-glc22-4.3.0-2.9.12
        libpthread.so.0(GLIBC_2.0)   is needed by fglrx-glc22-4.3.0-2.9.12
oh yeah i am running slack 9, with everything installed, apart from kde and gnome.

any ideas?

cheers dude
 
Old 06-07-2003, 06:57 AM   #11
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
I use this procedure.
I also never bothered with the Check.sh and they work just fine for me with glibc-2.3.
Code:
>pkginfo -i | grep glibc
glibc 2.3.2-1
Code:
>fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon 8500 DDR Pentium 4 (SSE2)
OpenGL version string: 1.3 (X4.3.0-2.9.12)
 
Old 06-07-2003, 09:23 AM   #12
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
this is probably a really stupid question but when i run sh make.sh, i get:

Code:
kernel includes at /lib/modules/2.4.20/build/include not found or incomplete
file: /lib/modules/2.4.20/build/include/linux/version.h
bash-2.05b#
what is it looking for?

cheers
 
Old 06-07-2003, 09:49 AM   #13
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
Make sure you have the kernel-sources installed.
You'll have to get them through a Slack mirror since they weren't on the .iso IIANM.
 
Old 06-07-2003, 06:25 PM   #14
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
ok, i get this far:
Code:
bash-2.05b# cd ../
bash-2.05b# ls
build_mod              fglrx.2.4.18-17.8.0.o  fglrx_info.txt   make_install.sh
fglrx.2.4.18-17.7.x.o  fglrx.2.4.20.o         make.2.4.20.log
bash-2.05b# sh make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
  See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module fglrx loaded, with warnings
done.
bash-2.05b# ls
build_mod              fglrx.2.4.18-17.8.0.o  fglrx.o         make.2.4.20.log
fglrx.2.4.18-17.7.x.o  fglrx.2.4.20.o         fglrx_info.txt  make_install.sh
now, i start getting a bit confused from here:
Quote:
then I copy ~/fglrx/usr/X11R6/bin/fglrxconfig, fgl_glxgears and fglrxinfo into /usr/X11R6/bin

Follow the same procedure with the content of ~/fglrx/usr/X11R6/lib, but I backup my existing /usr/X11R6/lib/libGL.so.1.2 to DRI-libGL.so.1.2 before copying over. The rest in ~/fglrx/usr/X11R6/lib/modules won't overwrite existing files.
where are these?: ~/fglrx/usr/X11R6/bin/fglrxconfig, fgl_glxgears and fglrxinfo

and by follow the same procedure with the content of ~/fglrx/usr/X11R6/lib
starting from where? just the copy procedure??

cheers for your help
 
Old 06-07-2003, 06:40 PM   #15
N_A_J_M
Member
 
Registered: Aug 2002
Location: Whangarei New Zealand
Distribution: Slack 8.1
Posts: 300

Original Poster
Rep: Reputation: 30
ok i sussed part of it out; i copied the first lot of files and backed up my libGL.so.1.2 file and copied the files in the lib directory, my only other question is do i have to copy the files in the module directory to the module directory too??

Code:
hen I copy ~/fglrx/usr/X11R6/bin/fglrxconfig, fgl_glxgears and fglrxinfo into /usr/X11R6/bin

Follow the same procedure with the content of ~/fglrx/usr/X11R6/lib, but I backup my existing /usr/X11R6/lib/libGL.so.1.2 to DRI-libGL.so.1.2 before copying over. The rest in ~/fglrx/usr/X11R6/lib/modules won't overwrite existing files.
yeah almost there!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 07:52 PM
Problems with GLX on ATI Radeon 9100 IGP Narooze Linux - Software 2 03-01-2005 08:41 AM
Problems with Rad 9100 (ATI Drivers) and Xawtv jimdaworm Slackware 2 07-02-2004 06:49 AM
ATI Radeon Drivers paul_linux_user Linux - Hardware 1 05-24-2004 05:41 PM
ATI radeon drivers malcidragon Linux - Hardware 9 07-11-2003 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration