LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   ATA 100 Support (https://www.linuxquestions.org/questions/linux-general-1/ata-100-support-3995/)

Stephanie 07-05-2001 04:37 PM

ATA 100 Support
 
How do I get Linux to recognize udma 100 promise controllers on my Asus A7V board. Also, how would Linux see them... as hda, hdb, etc.

jharris 07-05-2001 05:16 PM

In the 2.4 tree have a look at ATA/IDE/MFM/RLL Support --> IDE, ATA and ATAPI Block devices --> PROMISE PDC20246/PDC20262/PDC20267 support

That should be the module/code you want to add to the kernel. The controller itself is seen as another IDE channel so will form ide3 and ide4 supporting hde thur hdh. Have a read of /usr/src/linux/Documentation/kernel-parameters.txt to see how to tell the kernel a about the new controllers (Although this might not be necessary, I think I eneded up doing it).

Post any more questions back here, I can always have a look a my friends machine who I installed to tell you exactly what I did.

cheers

Jamie...

Stephanie 07-06-2001 09:50 AM

I am sorry, but I am looking through / and I do not see 2.4 tree. Is it in the src files? Be advised, I am running mdk 8.0 with the 2.4.4 kernel

jharris 07-06-2001 09:52 AM

You should be able to see it. Do a
Code:

make menuconfig
and follow the directions from there (would have been sensible if I'd of mentioned this in the first place eh!?? Sorry...) Its definately in 2.4.5 and I think the kernel that I used was 2.4.3 so your 2.4.4 should be a winnder.

HTH

Jamie...

PS - you moving the a HDD from on of your other controllers? If you do then you'll need remember to edit /etc/fstab and /etc/lilo.conf to reflect the change of IDE devices before you make the swap?

Stephanie 07-06-2001 01:17 PM

Is there any way to install Linux MDK with the drive on the 100 port controller to begin with, or do I have to install from an IDE port, then move it over?

Also, what would be the best way to edit my files? It is currently listed as hda, and I will have hdb.

And one more question... will I still be able to see and read/write to my Windows drive?

jharris 07-06-2001 03:06 PM

You will be able to install straight to the ATA-100 drive so long as the kernel that used by the installer recognises the controller. I dunno wether this is the case, the new ones probably do so you might be in luck.

As for editing the files - use any editor you want, pico, vi, emacs, joe whatever takes you fancy. The only reason I mention this is becuase when you move the drives your /etc/fstab file will still be trying to mount the partitions from /dev/hda instead of /dev/hde so will moan and stop.

As for accessing the Windows partition - yeah, everything will be the same just in a slightly different place, hence the /dev/hdX changing.

HTH

Jamie...

rdaves@earthlink.net 08-31-2001 08:27 PM

I just do not understand
 
I have been trying to get my ATA100 controller recognized, and nothing I read is making sense. I think that I have to recompile my Kernel and then do something with block devices, but nothing I have read seems able to get me there.
I think I have to do a make menuconfig, but I am stopped

Here's what happens:
---------------------------------------------------
[root@localhost /root]# /usr/bin/make menuconfig
make: *** No rule to make target `menuconfig'. Stop.
---------------------------------------------------
What the heck is wrong? I have cd'd to /boot/ and tried the same command with the same result.

I have gone to Red Hat HowTo's and was told to do make menuconfig, but there is nothing about what directory you should be in or what preliminaries you have to perform.

I read somewhere that the make menuconfig command won't work unless you have the source code installed, so I went to my Linux install CD and found /RedHat/RPMS/kernel-2.4.2-2.i386.rpm (this is from memory) and tried to install it, got a bunch of cryptic technobabble and don't think anything happened.


jharris 09-02-2001 09:32 AM

You want to run make menuconfig from /usr/src/linux - the normal place you'd find your kernel config, although it can be put else where.

HTH

Jamie...

rdaves@earthlink.net 09-02-2001 09:51 PM

Jamie
 
Re:
>You want to run make menuconfig from /usr/src/linux - the normal >place you'd find your kernel config, although it can be put else where.

In RedHat V7.1, there is no /usr/src/linux. The closest I can get is /usr/src/redhat. And within this directory, there is no folder named "linux".

My vmlinuz file is in /boot/ but I am not sure this will do me any good as this is the compiled kernal from when I did the original install of RedHat V7.1.

I read somewhere that you need to have the source installed, and that you need to be in that specific directory in order to use [make menuconfig]. I have found the Linux source rpm on the install cd, but was unable to install it.
1.) I wonder if I need to just copy it over and then run [make menuconfig]?
2.) Also, if I recompile Linux and just change the part relating to ATA100 and nothing else, does the resulting compile keep all the other settings that were in the original kernel?

I am a little goosey about doing a compile of the kernel. It is dangerous territory for the newbie.

Thanks

PS: Just tried to copy kernel 2.4.2-2.i386.rpm over to /usr/src/linux. Then tried [make menuconfig]. No success.
Also tried [rpm -Fvh /usr/src/linux/kernel 2.4.2-2i386.rpm] and got nowhere.

What am I supposed to do here?:

OldFrog 09-03-2001 01:25 PM

That's weird, I have an A7V rev 1.02 and installed Mandrake 8.0 with full detection of the Promise Controler.
That was different with Mdk 7.1 and 7.2
The default install 2.4.3-20 kernel in the 8.0 distro manages the controlers without any trouble.
Dud you install it by upgrading from a 7.2 distro ?

You should give a try to fdisk on command line and test all your disks. You should be able to see all disks you installed, then the partitions on them.

Promise devices are hde thru hdh

rdaves@earthlink.net 09-03-2001 01:52 PM

Did you have to do anything else?
 
If the install process recognized the ATA100 controller, was that all there was to it? Didn't you have to change some configuration settings somewhere? Like, didn't you have to say something somewhere about block devices?

rdaves@earthlink.net 09-03-2001 02:02 PM

Jamie
 
Can you help me on this one? I am really stuck.
I think I have to have Linux source on my HD in order to use [make menuconfig]. I have found what I think is the kernel source rpm file on my install cd, but when I try to install, I get a bunch of gobbldygook that says something like:
----------------------------------------------------------------------------------
0 source files found and 1 binary, installing binaries
"[filename] conflicts with vmlinuz installed kernel"
(probably about 100 similar messages)
-----------------------------------------------------------------------------------

I get no further information that might help me figure out what is wrong.

I have also tried to copy the rpm over to my HD from the CD, then do rpm -Fvh [filename] without success. Nor can I use [make menuconfig]

Questions:
1.) Why can't I just click on the kernel rpm and have the darned thing install itself?
2.) Am I going to have to download the kernel source from RedHat in order to get this thing to work? Right now, I am using an ISP/phone line that only provides 24,000 bps, no more.

Lazlo 09-03-2001 03:26 PM

rdaves,

For RH Linux 7.1, the kernel source is on the 2nd cdrom (CD 2). Its called kernel-source-2.4.2-2.i386.rpm. under the RedHat/RPMS directory on the cdrom. Go to the direcotry and type: rpm -ivh kernel-source-2.4.2-2.i386 and this should install the source code, creating the /usr/src/linux directory (or i've seen that this may be called /usr/src/linux-2.4 also). Hope this helps.

Lazlo

rdaves@earthlink.net 09-04-2001 11:24 AM

Lazlo
 
Thank you, Thank you, Thank you:D :D :D

rdaves@earthlink.net 09-04-2001 11:27 PM

Okay, now what?
 
I suspect the next time I try to boot Linux, I will be in the grease up to my armpits.

I found the kernel source and got it properly installed in /usr/src/linux-2.4.2
then
make menuconfig
make dep
make bzimage
make modules
make modules install

Copied new kernel (bzImage) to /home/ as backup
Copied new kernel to /boot and named it mykernel-2.4.2

Now here's where it gets fuzzy
I edited my lilo.conf and here it is:
-------------------------------------------------
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=new
image=/boot/vmlinuz-2.4.2-2
label=linux
read-only
root=/dev/hda5
append="hdd=ide-scsi"

image=/boot/mykernel-2.4.2
label=new
root=/dev/hdg5
append="ide2=0x9400, 0x9002 ide3=0x8800, 0x8402"

other=/dev/hda1
optional
label=dos
--------------------------------------------------
Here's the problem: I think the entry /dev/hdx in the new section changes. I have read, but don't remember where, that ATA 100 recognizes the hard drives not as hda and hdb, but something else, like hdg and hdh. I just guessed at the stuff in the section "image=/boot/mykernel-2.4.2". I guessed at "root=/dev/hdg5" and I guessed at the append="ide2=0x9400..."

Questions:
1.) What does Linux recognize the Hard Drives as when they are attached to the ATA 100 controller?
2,) I am booting from a floppy, so will this lilo.conf file even be used?
3.) Should I change something on the boot floppy?
4.) Where else will I be in trouble?

I'm not a drinking man, but if I get this mother to work, I am going to have an extra caffeine free diet coke or maybe even a huge glass of cranberry juice!


All times are GMT -5. The time now is 03:05 AM.