LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-18-2005, 05:30 PM   #1
letsinstalllinu
LQ Newbie
 
Registered: Dec 2004
Posts: 11

Rep: Reputation: 0
Apache stoped working


Hey.

I powered my machine, loaded linux and tried to access localhost. It doesn't work.

I went to the shell, typed "httpd" and it said that...

Code:
Syntax error on line 205 of /etc/apache/httpd.conf:
Cannot load /usr/libexec/apache/mod_vhost_alias.so into server: 
/usr/libexec/apache/mod_vhost_alias.so: cannot open shared object file:
No such file or directory
I went to that file and commented out that line.

Then I ran the "httpd" again and the same error but in the next line. Tried logging out, rebooting, changing the user... nothing worked.


This was working a few weeks ago. I haven't been using Linux...


Any ideias on how to fix this?

Thanks for your help.
 
Old 01-18-2005, 05:43 PM   #2
letsinstalllinu
LQ Newbie
 
Registered: Dec 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Well I saved the httpd.conf.default file as httpd.conf and now it works.

Don't know why the other got corrupted.
 
Old 01-18-2005, 06:07 PM   #3
letsinstalllinu
LQ Newbie
 
Registered: Dec 2004
Posts: 11

Original Poster
Rep: Reputation: 0
Now I was configuring the file again and...

Code:
Cannot load /usr/libexec/apache/libphp4.so into server: 
/usr/libexec/apache/libphp4.so: cannot open shared object file: No such file or 
directory
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless stoped working Nuke361 Linux - Newbie 1 05-19-2004 05:43 PM
CDROM stoped working Joey.Dale Linux - General 6 11-27-2003 11:45 PM
CD-ROMS stoped working..... J.T. Mandriva 19 11-13-2003 02:23 AM
mozilla stoped working allohakdan Linux - Newbie 4 10-30-2003 12:49 PM
smb_auth program stoped working! antken Linux - General 0 09-03-2002 10:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 03:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration