LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 02-14-2003, 04:31 AM   #1
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Rep: Reputation: 30
anti aliasing in certain gnome apps like gimp


I have dropline gnome installed and want to use font anti aliasing.

Dropline supports this for certain apps right out of the box yet others, like the gimp, will not do it no matter what I try. The Gimp and Sylpheed will try though but I get really ugly fonts with jagged edges and such.

I have searched google and LQ and have tried the tips I found:

My TTF dir is in my XF86Config and it's also in XftConfig.
I added export GDK_USE_XFT=1 to my .xinitrc and the freetype module is being loaded (checked the log).

Btw, I saw a tip on adding export GDK_USE_XFT=1 to the bash.rc file but I cannot find that.


Any thoughts on this?

HC
 
Old 02-14-2003, 05:36 AM   #2
llama_meme
Member
 
Registered: Nov 2001
Location: London, England
Distribution: Gentoo, FreeBSD
Posts: 590

Rep: Reputation: 30
I think stable versions of the gimp use gtk-1.2, which doesn't support font antialiasing.

Alex
 
Old 02-14-2003, 05:54 AM   #3
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Original Poster
Rep: Reputation: 30
ah, that would explain that then

I've seen Sylpheed with anti aliased fonts though so there should be a way to that. I'll keep messing with this.

Thanks for your reply!
 
Old 02-14-2003, 09:01 AM   #4
llama_meme
Member
 
Registered: Nov 2001
Location: London, England
Distribution: Gentoo, FreeBSD
Posts: 590

Rep: Reputation: 30
RE setting GDK_USE_XFT, try doing this in /etc/profille, then rebooting. In the meantime, you can just set GDK_USE_XFT in a terminal window and run Gtk applications from that (assuming they use Gtk 2.x).

Alex
 
Old 02-16-2003, 06:22 AM   #5
Hcman
Member
 
Registered: Jan 2003
Location: Holland
Distribution: OpenBSD 3.6 - Arch Linux 0.7
Posts: 210

Original Poster
Rep: Reputation: 30
well...got my TTF fonts loaded; freetype loads;export GDK_USE_XFT=1 is in /etc/profile.

In evolution (1.2.0) I see several fonts with b&h behind them. These look really edgy when I use them. Still I don't see any true XFT fonts like I do in KDE.

I'll mess with my setting some more.

Thanks for your help!

HC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable AA (anti-aliasing) in Fedora Core 3 Gnome madiyaan Linux - Newbie 2 01-19-2005 01:26 PM
anti-aliasing in gimp nibz Linux - Software 1 09-28-2004 06:25 PM
Problem with Anti-Aliasing of gnome-based applications' fonts on OpenBSD 3.5 oCompulsive *BSD 0 07-07-2004 07:50 AM
who's using anti-aliasing? webazoid Linux - Software 0 07-04-2004 08:58 AM
Anybody ever had problems with anti-aliasing working under gnome but not KDE apps? scobiej Linux - General 0 11-26-2003 03:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration