-   Linux - General (
-   -   another newbie with Kernel compile problems (

tinyredpea 10-03-2004 10:20 PM

another newbie with Kernel compile problems
Hi, I just installed SUSE 9.1 and I am trying to install my linksys WPC54G network card. I found out that I need to use ndiswrapper but I need to compile my kernel before I can get ndiswrapper installed. I have kernel 2.6.5-7. The following is what the source I was using instructed me to do:

1. Compile and install
As root run

> make install

This should compile both the kernel module and the userspace utilities.
when I type in this command I get this:
linux:/lib/modules/2.6.5-7.108-default # make install
bash: make: command not found

please help me I have tried everything that I know of(which isnt much) any help will be greatly appreciated

btmiller 10-03-2004 10:52 PM

Have you managed to configure the kernel with make config (or an equivalent) yet (i.e. has any make command worked for you)? If not, make sure that you have make installed -- if you have SuSE 9.1 personal the software development tools are not included, but there are many threads here detailing how to install them. If make worked before but has stopped working, make sure your PATH environment variable contains the directory make is in.

nikkkko 10-04-2004 12:13 PM

If you have 9.1 personal you'll need:


Don't make life even more difficult for yourself, (like I did), by downloading the source for gcc and trying to compile it yourself - this is hard because gcc is itself the compiler. Chicken and egg. Instead, go to the suse ftp site here and download the appropriate rpm(s) (pre-packaged software) which you install using SuSE's YAST tool. Open the rpm(s) in Konquerer and simply click on 'Yast Install'.

tinyredpea 10-05-2004 07:02 PM

Ok, thanks, I installed all the necessary tools, but now i have another problem when I try any command i get this:
linux:/lib/modules/2.6.5-7.108-default # make install
make: *** No rule to make target `install'. Stop.
linux:/lib/modules/2.6.5-7.108-default # make configure
make: *** No rule to make target `configure'. Stop.
Please help

amfoster 10-05-2004 07:08 PM

sounds like you are running those make rules in the wrong directory.

The /lib/modules/version dir is where the compiled modules will be.

If you ar3e compiling the kernel you shud be in /usr/src/linux. I may be way off, since I didnt thoroughly read the thread, but I don't recall a Makefile being in the module\s directory.

tinyredpea 10-05-2004 07:45 PM

nope the only file i found in : usr/src was pakages thers no linux in there

comprookie2000 10-05-2004 08:32 PM

You are going to have to start from the beginning one of the first things you do is ln -s <new kernel-source> linux

tinyredpea 10-10-2004 06:20 PM

Ok thanks ill give it a try

All times are GMT -5. The time now is 08:06 PM.