LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-31-2003, 10:33 AM   #1
higgies
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Rep: Reputation: 0
Another Dual-boot problem


Hi there,

Here's my situation:

Windows XP Pro
Windows 2000 Pro
RedHat Linux 8.0

I had been successfully running RedHat 7.0 and all was fine. I reformatted my ext3 partition and installed 8.0. I did not want to use LILO, I wanted to continue using ntldr. When I install LILO on the mbr, I can access Linux and the DOS install. If I put ntldr back on the mbr and use the bootsect.lnx method from the boot.ini, I only get "LI" when selecting Linux from the Windows boot selector.

My Linux install is on /dev/hda4 of a 60GB hard drive. It's waaay down there, on the end of the hard drive. Could this be an issue? If I use the boot floppy, I can get into RedHat fine. Then I used the:

dd if=/dev/hda4 of=bootsect.lnx bs=512 count=1

command to make my bootsect.lnx file. When I try to use it though, it won't boot. When I re-install LILO, my lilo.conf file has no root parameter for the linux install. It only has a reference to /boot/<image_name>

Any help would be appreciated!!

Thanks,
Paul
 
Old 03-31-2003, 11:54 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
You should have
boot=/dev/hda4
in lilo.conf. Then install lilo, use 'dd....' as before, copy the file etc.
Should work.
 
Old 03-31-2003, 12:34 PM   #3
higgies
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Original Poster
Rep: Reputation: 0
I'm about to reinstall LILO, but...

Here is my lilo.conf file:

prompt
timeout=50
default=DOS
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.18-27.8.0
label=linux
append="hdc=ide-scsi root=LABEL=/"
read-only
initrd=/boot/initrd-2.4.18-27.8.0.img

other=/dev/hda1
optional
label=DOS

You can see that there is no root parameter. I believe my linux install is on /dev/hda4, but when I do the dd command, the resulting file does not allow boot. Any thoughts on why my lilo.conf file is like this? Is it a feature of the new version of LILO? It works when I use LILO, but not when I use ntldr....

Thanks!
 
Old 03-31-2003, 12:53 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
I think you can change your lilo.conf to
prompt
timeout=50
default=linux
boot=/dev/hda4
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.18-27.8.0
label=linux
append="hdc=ide-scsi root=LABEL=/"
read-only
initrd=/boot/initrd-2.4.18-27.8.0.img

You don't have 'root' alone, but it's in 'append' - passed to kernel, so you don't need to worry about this.

Save the file. Run 'lilo'. Then
dd if=/dev/hda4 of=bootsect.lnx bs=512 count=1
and copy the file to Windows C:.

When you don't install LILO to /dev/hda4 (you install it using 'lilo' command), you get 'empty' bootsect.lnx file. That's why it won't boot.
 
Old 03-31-2003, 01:07 PM   #5
higgies
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Aaah....

Well, to avoid the 1024 cylinder thing, I decided to repartition my drives with PartitionMagic and create my linux partition at the beginning of a slave drive. I'm going to re-install linux and I'll make sure to install LILO into my linux partition.

Thanks, I'll let you know how it goes...
 
Old 03-31-2003, 03:12 PM   #6
higgies
LQ Newbie
 
Registered: Mar 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Well, I re-installed Linux to the first partition of the secondary drive. I also installed LILO there. So far, it seems fine except that when I choose Linux from the ntldr menu, I get the LILO menu. I am removing the prompt parameter from the lilo.conf file and making linux the default. I am hoping that this causes it to boot directly to linux when I select it from the ntldr menu.

Thanks for the help!
 
Old 04-01-2003, 05:24 AM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Removing prompt (or making the wait time really short) should work correctly. But it's a good idea to have a choice, especially to be able to boot 'failsafe' kernel or to have an option to choose old kernel when you compile a new one.

But that's OK.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help fixing boot problem on Ubuntu/WinXp dual-boot Ay-Karamba! Linux - General 5 09-06-2005 10:20 PM
Problem with dual boot/dual drive setup Norab Linux - Hardware 10 08-29-2005 04:13 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 02:44 PM
problem with Installing red hat linux dual boot(/boot < for 1024 cylinders ) praveenb Linux - Newbie 2 02-13-2004 09:49 PM
Dual Boot Problem mainak Linux - General 4 04-12-2003 03:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 02:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration