LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-12-2007, 12:13 PM   #1
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
ALSA problems


I'm running Slackware 11.0 with my own 2.6.18.1 kernel. When booting my pc and trying to play music with xmms, I get the message "the sound device is busy". I have to manually load the modules snd-mixer-oss, snd-seq-oss and snd-pcm-oss to make my sound work.

When running alsaconf I get "No supported PnP or PCI card found."
 
Old 01-12-2007, 01:55 PM   #2
The_paladin
Member
 
Registered: Feb 2006
Distribution: Debian "Etch"
Posts: 47

Rep: Reputation: 15
Hmm, have you compiled your soundcard as included in the kernel or as a module? Not compiling the soundcard as a module can, in my experience, cause trouble with alsaconf.
 
Old 01-12-2007, 02:15 PM   #3
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
I think so:
Code:
bash-3.1$ /usr/pkg/sbin/lspci  | grep audio
00:06.0 Multimedia audio controller: nVidia Corporation nForce MultiMedia audio [Via VT82C686B] (rev a1)
And when I run "make menuconfig", in ALSA -> PCI devices, the "Intel/SiS/nVidia/AMD/ALi AC97 Controller" entry is marked as a module.
 
Old 01-12-2007, 03:43 PM   #4
The_paladin
Member
 
Registered: Feb 2006
Distribution: Debian "Etch"
Posts: 47

Rep: Reputation: 15
Wierd.
Well, I'm out of ideas, but if I were in your shoes, I would investigate how Alsaconf detects soundcards; It seems that it's there your problem lies, IMHO.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with ALSA VrilDox Slackware 2 10-03-2004 01:12 AM
Problems with ALSA shane25119 Linux - General 2 09-03-2004 04:01 PM
Problems with OSS while trying to avoid problems in ALSA (scratchy sound) GT_Onizuka Linux - General 1 02-05-2004 11:55 PM
alsa problems, please help matjazk Slackware 16 12-15-2003 05:45 AM
alsa problems watashiwaotaku7 Linux - Software 19 02-23-2003 12:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration