-   Linux - General (
-   -   alsa in new kernel 2.6 volume 0 at startup (

demmylls 01-19-2004 02:37 PM

alsa in new kernel 2.6 volume 0 at startup
i know there is tutorial that taught how to correct alsa volume that always rewrited to 0 or mute.
below is the actual howto copied and pasted from the turorial:-

As I also compiled this into the kernel, I created a /etc/aumixrc file, containing the following:


Obviously, customise to your own liking. I created this file so that RedHat wouldn't keep overwriting it with 0 volume, as the do to /etc/.aumixrc

You then need to add the following to /etc/rc.local to have sound load on startup.

/bin/aumix-minimal -f /etc/aumixrc -L >/dev/null 2>&1;


i've tried the method above but dont work at all.

how to fix this so that alsa will save my mixers setting everytime i shutdown and then reload my previous setting when i reboot?

i'm using redhat9 kernel 2.6.

alsa driver and soundcard support are compilled directly into my kernel

Rounan 01-19-2004 03:20 PM

First, install alsa-utils and alsa-tools if you haven't already done so - can be found at the alsa website.

One of the things in those packages, can't remember which, is alsactl. This is a program which manages settings such as volume.

Boot up, and adjust your volume the way you like it, however you normally would. then, do: alsactl store
This stores current setting in the config file. default is /etc/asound.state.

Then, add to whatever init script corresponds to your default runlevel:
alsactl restore

and to your shutdown script:
alsactl store

This will save your settings on exit, and load them on reboot.

I'd tell you which files to use exactly, but I'm on Debian and runlevels can vary from system to system. If you don't know what init script to use, read:

and it should give you the lowdown for your particular system.

Hope that helps!

Rounan 01-19-2004 03:46 PM

After poking around the ALSA scripts a bit, it seems that the default alsa init script should take care of this on its own - in version 1.0.1, at least, which I just compiled today.

You can still do it the way described above, but it might be worth it to upgrade - then again, it might not. ;)

Just a thought.

demmylls 01-20-2004 05:12 AM

i have installed alsa driver directly into kernel 2.6
can i just recompile alsa-driver, alsa-util, alsa-lib and alsa-tools and then install them and dont care about the alsa installed into kernel 2.6?

Rounan 01-20-2004 08:00 AM

The answer SHOULD be yes, but I ran into problems when I did the same.

You're going to want to do one of two things:

Compile only sound support (soundcore) into your kernel, and build ALSA separately, changing versions as you like with add/remove packages.

Compile ALSA into the kernel, patching the kernel source with the latest version of ALSA - there's a guide to this linked off the alsa webpage. it might be a tad hard to find, but it just involves copying the appropriate directories from the latest alsa-driver.tgz to /usr/src/linux/sound.
This method means recompiling the kernel everytime you want to upgrade alsa though.

If your only problem is saving/loading volume settings, it's probably not worth upgrading alsa. Just fiddle with the config scripts until you get it behaving properly. ;)


demmylls 01-20-2004 11:11 AM

after instaling alsa-utils which contain program of alsactl, i still cant execute alsactl using console.

and i searched for alsactl i dont even find in my drive.

Rounan 01-20-2004 11:25 AM

Ummm.... hm. how 'bout that....

did you install an RPM or compile from source?
did you also install alsa-tools? I'm taking a wild guess, but utils might in some way build off of it.

Maybe... uhhh... poke it... harder?


demmylls 01-20-2004 11:37 AM

i compiled it from source code and i dont find rpms for my redhat9.
and after reading alsa-tools readme none is related to my soundcard that is creative soundblaster vibra 128

so i dont compiled and install alsa-tools

i installed alsa-lib, alsa-firmware, alsa-oss and alsa-utils

i dont compile alsa drive coz when i do ./configure it said i already compiled it into kernel.
so i guess i no need to intall alsa driver so i dont isntalled it.

where can i find alsa 1.01 rpms for redhat9?

Rounan 01-20-2004 12:23 PM

I'm at a loss...

if utils compiled and installed OK, alsactl should work...
You do have to be root to use it, apparently, just checked... could that be it?


demmylls 01-20-2004 03:02 PM

everytime i compile anything i must 1st su to root user
from there i install and i tried to run it from root.

nvm i'll try to recompile my kernel and then try again everything from beginning then i post here the result

All times are GMT -5. The time now is 11:01 AM.