LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 03-23-2005, 07:02 PM   #1
gbkyle
Member
 
Registered: Sep 2004
Location: NJ USA
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
ALSA atiixp 2.6.11-4 problems. (sound hangs)


I have put out a lot of posts about this, but not really getting a good reply.. i was suggested to upgrade my kernel from 2.6.10 to 2.6.11 so i did. Im still experiencing sound problems. After rebooting, the modules for alsa will load fine, everythings ok. At console.. i do mplayer blah.mp3 and it'll play the 4 second clip through, but hang on the last second.. mpg123 hangs the second it starts.

I tried reinstalling the alsa-drivers/alsa-headers/alsa-utils. My make.conf says:

USE="kde alsa oss ati nptl ithreads"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
MAKEOPTS="-j2"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/"
ALSA_CARDS="atiixp"
ALSA_TOOLS="atiixp"


my /etc/modules.d/alsa reads:


alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.8 ---
#options snd device_mode=0666
alias snd-card-0 snd-atiixp
alias sound-slot-0 snd-atiixp
# --- END: Generated by ALSACONF, do not edit. ---


I dont know what to do anymore, i've tried everything I could think of, any help would be appreciated.. thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA problems with FC3 (ATIIXP) Twey Linux - Software 0 02-13-2005 02:58 PM
atiixp alsa problems - playback skipping - spent two weeks on this - NEED YOUR HELP damartin Linux - Software 13 01-09-2005 07:48 PM
Alsa and atiixp misconfigured NEC-LL9109 Laptop Stabby Linux - Laptop and Netbook 1 09-06-2004 05:58 AM
ATIIXP Sound Freezes alsamixer when you change volume JSylvia007 Linux - Hardware 1 08-04-2004 12:38 AM
System hangs when probing alsa sound modules milkycow Slackware 2 04-11-2004 05:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 10:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration