-   Linux - General (
-   -   AHHH!!! kernel upgrade disaster! (

axion0917 12-10-2003 10:05 AM

AHHH!!! kernel upgrade disaster!
Ok...I thought I knew what I was doing...apparently not. I've read a lot about the 2.4.22 bug that could easily compromise my I decided to upgrade to 2.4.23. I'm using WindowsXP now on another PC...I'm using Slackware 9.1 and I used installpkg to install the following package: kernel-ide version 2.4.23. Everything went well and when I rebooted 3 kernel modules that I was using failed to load, including my network driver. They are: agpgart, 8139too, and ide-scsi. Is there an easy fix? Please let there be a way...any help appreciated greatly. I will be watching this thread closely :D Thanks

Breezwell 12-10-2003 10:15 AM

Check your loaded modules with following comamnd:
This will tell you what, if any, modules are loaded and running. If the modules you need are not loaded and the drivers you are using as modules where compiled into the kenrel as modules, run following command to try and load them manually:

Breezwell 12-10-2003 10:19 AM

Sorry about that, my system just had a cramp:

Check your loaded modules with following: lsmod

If you compiled the kernel to use modules with respect to the drivers you need, you can try and load them manually with following command: modprobe <driver name>

Then run lsmod again to see if they are loaded.

I am not familiar with Slackware, but check to see if you have something along the lines of /etc/modules.autoload.d If you do, you can list the drivers you need loaded as modules in the file located in this directory. Once this is done, whenever you boot, your modules should load no problem.

Also, double-check your kernel configuration to make sure you compiled the drivers as modules or not.

Good luck.

BSlack 12-10-2003 10:22 AM

I think you have to install the kernel-module package too...

axion0917 12-10-2003 10:24 AM

Hi thanks for the reply. lsmod reports that no modules are loaded...and modprobe says it cant find the module...same error as the init script which is why i dont have them loaded to begin with...any clue?

tbranham 12-10-2003 10:25 AM

Hi there,
Did you only install the 'kernel-ide-2.4.23-i486-1.tgz' package?

Here are the instructions per the Slackware Security email that I received:

Updated packages for Slackware 9.1:

An alternate kernel may be installed. Those are found in this directory:

ALSA has also been updated to 0.9.8 and compiled for 2.4.23. These
packages will also be required to use the ALSA sound system:

The XFS patched kernel requires different kernel modules. If you use
the XFS filesystem and XFS patched kernel (xfs.s), these packages
contain kernel modules compiled against 2.4.23-xfs:



Use upgradepkg to install the new kernel, kernel-modules, and alsa packages.
After installing the kernel-ide package you will need to run lilo ('lilo' at
a command prompt) or create a new system boot disk ('makebootdisk'), and

If desired, a kernel from the kernels/ directory may be used instead. For
example, to use the kernel in kernels/scsi.s/, you would copy it to the
boot directory like this:

cd kernels/scsi.s
cp bzImage /boot/vmlinuz-scsi.s-2.4.23

Create a symbolic link:
ln -sf /boot/vmlinuz-scsi.s-2.4.23 /boot/vmlinuz

Then, run 'lilo' or create a new system boot disk and reboot.


Try upgrading the kernel modules (and ALSA patches as well) too and see if that helps. Let me know how it all works out.

axion0917 12-10-2003 10:32 AM

:( i just downloaded kernel-modules from my xp box and burned it to a cdrw but when i try to mount the cd (or any cd for that matter) on my slackware box i get /dev/cdrom is not a valid block device. what should i do???

BSlack 12-10-2003 10:40 AM

Check if /dev/cdrom exist, ls -l /dev/cd*.
Or try /dev/scd0.

axion0917 12-10-2003 10:43 AM

same error for /dev/scd0 and /dev/sr0 and /dev/cdrom exists

axion0917 12-10-2003 10:43 AM

i can mount a floppy but not sure how to split the modules file (its about 10mb)

BSlack 12-10-2003 10:46 AM

If you haven't delete your old kernel try to boot it

tbranham 12-10-2003 10:46 AM

What about placing the bare.i kernel image for 2.4.22 onto a floppy (via the win box) and booting that way? It would restore you to your previous functionality until you get the rest of the upgrades taken care of...

axion0917 12-10-2003 10:47 AM

no i didnt delete it, unless slapt-get automatically would i tell, and how would i boot it?

axion0917 12-10-2003 10:48 AM

thanks tbranham....gonna try that now....thank you all for trying to help so far

BSlack 12-10-2003 10:51 AM

Are you using lilo? There should be the old kernel entry on the lilo menu unless removed from the upgrade.

All times are GMT -5. The time now is 03:34 PM.