-   Linux - General (
-   -   After upgrading Samba, gnome is broken (

aschoessler 06-16-2006 03:07 PM

After upgrading Samba, gnome is broken [Resolved]
Hello all,

We recently did a Samba upgrade during which we removed some packages to bypass dependency issues during install. Unfortunately, one of these packages was part of gnome. When RedHatEL4 loads, I can log in at the prompt, but a terminal window and a cheesy clock are displayed.

So today, I ran


$ rpm -nodeps [all gnome packages on the system]
I then reinstalled all the gnome packages again, but the issue stays the same.

If I run:


$ startx
...I am informed that gnome cannot be started because it is already running. I also wiped out root's user settings for gnome (.gnome, .gnome-conf, etc.) as it should re-create them when it logs in.

If somehow I missed packages when I reinstalled gnome, how would I tell? Any ideas?

Thanks so much!

- Allen Schoessler

binary_y2k2 06-17-2006 11:55 PM

if gdm is running when you are trying startx you'll need to run this insted

startx -- :1

aschoessler 06-19-2006 12:38 PM

Thanks for the reply !

It seems that gnome wasn't installed correctly when I tried to install it. I force-removed Samba, reinstalled gnome, and then installed Samba again... That gave me my gui back.

Thanks heaps!

All times are GMT -5. The time now is 04:13 PM.