LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-09-2004, 11:09 AM   #1
Tinku
Member
 
Registered: Jul 2004
Location: INDIA
Distribution: SusE, Gentoo,Debian,FreeBSD
Posts: 197

Rep: Reputation: 30
adding an entry to /etc/fstab file and another query


Hello

i have a drive apart from the root partition,its a fat file system,.,
normally whenever i reboot this is what i do to mount it

mount -t vfat /dev/hda1 /mnt/ax/

Now ,I want to add this to the fstab file so that i dont have to mount whenever i reboot.
how do i do it?


also is there a way to make the drive's space into my present linux home??i am the single user of my system (home pc).......ofcourse after removing all the data on it ..

thanx for any suggestions

tinku

Last edited by Tinku; 06-03-2005 at 04:30 AM.
 
Old 08-09-2004, 11:47 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 261Reputation: 261Reputation: 261
Use your favorite editor and simply put in your fstab file:

Code:
/dev/hda1     /mnt/ax/      vfat     users     0  0
That would be the basic way, man fstab and mount for more details and options.
 
Old 08-09-2004, 12:14 PM   #3
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
you would want a line like this in /etc/fstab:

#this mounts /dev/hda of type auto onto /mnt/windows with the permissions shown...
/dev/hda1 /mnt/windows auto uid=1000,gid=1000,umask=002,exec,dev,suid,rw,auto,user 0 0

#this would mount it to /home/your_account_name/windows - so it is available in your home
/dev/hda1 /home/your_account_name/windows auto uid=1000,gid=1000,umask=002,exec,dev,suid,rw,auto,user 0 0

The directory ~/windows will have to exist - you must create it first

You can replace the filesystem-type "auto" with "vfat" if you want - but auto always worked for me
 
Old 08-11-2004, 08:35 PM   #4
Tinku
Member
 
Registered: Jul 2004
Location: INDIA
Distribution: SusE, Gentoo,Debian,FreeBSD
Posts: 197

Original Poster
Rep: Reputation: 30
thnx for both of u,,both worked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/fstab entry ryedunn Linux - Newbie 1 01-17-2005 01:45 AM
apt query concerning unstable security.debian.org entry f0rmula Linux - Software 2 12-03-2004 02:01 PM
entry in fstab file Tinku Linux - General 6 10-02-2004 12:06 AM
FC2 FSTAB Entry jeopardyracing Linux - Newbie 2 07-10-2004 09:53 AM
fstab entry albean Linux - Newbie 1 12-04-2002 01:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration