-   Linux - General (
-   -   add options in enlightenment menu (

watashiwaotaku7 02-20-2003 09:45 PM

add options in enlightenment menu
how does one add programs into the lists under the enlightenment user menu?


trickykid 02-21-2003 08:38 AM

You should find an enlightenment directory in your users home directory where you should find the applet config files there. They are basically plain text config files you just add and remove whatever programs you want by specifying the path, name, etc.

I am not at one of my machines to tell you the exact location but if you browse that directory you'll find them.

watashiwaotaku7 02-21-2003 02:52 PM

ok...i found the directory and ive tried putting programs into the config file but i cant seem to make it work...i think im having using the wrong syntax or else i just dont have any clue what im doing at all (good possibility) anyways im trying to follow something like this that is already in the file

"Emacs" "/home/justin/.enlightenment/gnome_icons/gnome-emacs.png" exec "emacs"

so this is what i tried to do with emelfm

"emelfm" "/home/justin/emelfm-0.9.2/" exec "emelfm"

i purge my config file chache then regenrate my menu and still mothing...can anyone tell me what im doing wrong?


Proud 02-21-2003 03:06 PM

Is /home/justin/emelfm-0.9.2/ the path to the icon you want to use?

watashiwaotaku7 02-21-2003 03:16 PM

i dotn have a certain icon i want to use that is the path to where emelfm is installed

Proud 02-21-2003 03:22 PM

Well I just noticed that the other, example, path is to an icon, so why dont you make your one to the icon of emelfm, or just some default icon? :)

watashiwaotaku7 02-21-2003 04:32 PM

makes sense...tried it...didnt help...

Proud 02-21-2003 04:48 PM

Tried using that gnome-emac's path? Just to get it working. Else I'm out of sensible guesses.

watashiwaotaku7 02-21-2003 06:21 PM

yeah i tried it and it didnt work

watashiwaotaku7 02-21-2003 06:58 PM

ok i edited another file and it seems to have worked as far as adding the program but it doesnt seem to execute it...if i type /home/justin/emelfm-0.9.2/emelfm into eterm it executes the program but with the same command in the exec portion of the config it doenst do anything anyone know how to fix that?

All times are GMT -5. The time now is 07:24 PM.