LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-29-2009, 08:52 AM   #1
nugganootch
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Acer Aspire One, Linpus Lite, Camera Problem


Hi

I have an Acer Aspire One running Linpus Lite. for some reason the camera has stopped working. When I click it to open I get the error messege "No supported video capture device found!". It used to work but stopped after I tried to set up a mobile broadband dongle.

I've searched all over the internet and a lot of people seem to have this problem but no one seems to have a solution. The camera doesn't work whether it's running on battery power or plugged in to the mains (someone suggested that the camera stops working when running on battery power).

Is there any way I can change it back to its factory settings or anything I can run that would help me find out how to fix this? I'm new to linux so I'm pretty useless!

ps if this is in the wrong forum would a mod please move it into the correct one
 
Old 10-31-2009, 08:25 PM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
hi

since your post count was 1, I know you have not posted on the dongle issue...which would need a separate post if you have not resolved it pls

2) webcams can be tricky beasts.

start with telling us the exact name / model of it pls

if your documents don't tell you and the vendor does not tell you via any website

then another way of starting it off is to look into your /var/log/messages and post the contents of just those line that refer to it

AND

in a terminal run
Code:
lsusb
and post the contents.

3) you can google those details as well.

4) Sorry if its dumbed down but basically it this

your os must have a driver to run it
linux uses a kernel or kernel module(s)
b) the module(s) must be loaded
c) any sound config file must not interfere with it
d) no other sound or action must interfere with it

let me generalise, your sound device, may be considered a microphone ..but if your microphone settings are set to only act as a sound out device....you will never get sound in.

(if you think I am joking I am not)

http://sidux.com/index.php?module=Wikula&tag=MicSounds

http://sidux.com/index.php?module=Wi...ag=Webcamlinks
 
Old 11-01-2009, 12:50 AM   #3
Wim Sturkenboom
Senior Member
 
Registered: Jan 2005
Location: Roodepoort, South Africa
Distribution: Slackware 10.1/10.2/12, Ubuntu 12.04, Crunchbang Statler
Posts: 3,786

Rep: Reputation: 282Reputation: 282Reputation: 282
I no longer have Linpus running on my AAO, but those are the details of the integrated webcam.
Code:
wim@aao:~$ dmesg |grep -i cam
[    0.000000]   AMD AuthenticAMD
[    6.676481] uvcvideo: Found UVC 1.00 device Acer Crystal Eye webcam (064e:d101)
[    6.678015] input: Acer Crystal Eye webcam as /devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0/input/input7
wim@aao:~$
I can't help you to get it going again, but it might help others to help you.
 
Old 11-01-2009, 06:45 AM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,055

Rep: Reputation: Disabled
http://hardware4linux.info/component/27432/

ok the module is uvcvideo

Code:
lsmod | grep uvcvideo (if no result then do next either command)

su && modprobe uvcvideo (OR)
sudo modprobe uvcvideo
I have a cam that uses this module myself and the best software to run it is guvcview as per previous link
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem recovering Linpus Lite on my Acer Aspire One. sjmarshy Linux - Newbie 10 09-09-2012 10:48 AM
Acer aspire one AOA101 linpus lite GUI loading problem. help please! nhomersc Fedora 0 10-20-2009 02:42 AM
Acer Aspire One: Linpus Lite fameONE Fedora 14 10-13-2009 11:07 PM
[SOLVED] Problem: Installing Ubuntu Netbook Remix on Acer Aspire One running Linpus Linux Lite wodehouse Linux - Laptop and Netbook 7 10-06-2009 10:04 AM
just got Acer Aspire 1 with Linux Linpus Lite, rebowen1943 Linux - Newbie 2 02-26-2009 10:54 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration