-   Linux - General (
-   -   About mkl library (

loyalnepali 05-26-2013 09:52 AM

About mkl library
I had downloaded l_fcompxe2013.1.117 and installed it too.While connecting to quantum chemistry software it doesnt show mkl library within it.You dont need mkl software provided you have intel fortran composer,do you?
How can I uninstall it? so that I could install again.How do you ensure whether it is installed properly or not?The question is long but Iam desparate to learn.

knudfl 05-26-2013 12:01 PM

I'd guess you will have to include MKL in the LD_LIBRARY_PATH, to use <quantum>.

Example :

$ export LD_LIBRARY_PATH=/opt/intel/mkl/lib/ia32:/opt/intel/lib/ia32:$LD_LIBRARY_PATH && <other-command>

If you have a surplus mkl-library in another location than the ifort compiler,
it should be possible to uninstall it. "l_mkl_**/install.txt :
".. Run <MKL-install-dir>/ ."


loyalnepali 05-26-2013 12:47 PM

Thanks for reply.I mean to ask should I download and install mkl library or the composer I mentioned comprises it. I tried to download separately the mkl library but it valids for a month then I need to buy which is impossible from my place Nepal.

knudfl 05-26-2013 03:22 PM

# 3 .

Please have a look at your install : You will find that mkl is already installed
as part of the ifort compiler. No need for a separate install, I think.

Which "quantum" software is it about ? ?


loyalnepali 05-26-2013 10:44 PM

It is Gamess US.If you are aware of that software I had problem in ./lked step.
Thanks for the information.Then the mkl seems not be working.There is a sub directory mkl within it.While giving the path in terminal /opt/intel/composer_xe_2013.1.117/mkl. It displays the message 'but this does not seem to exist on your system'.How to solve this.
Thanks for your interest.Hoping to get help in future as well.

knudfl 05-27-2013 01:14 AM

# 5 .

How to solve this
? Did you point to the MKL libraries ?

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/composer_xe_2013.1.117/mkl/lib/* && ./lked
I.e. /opt/intel/composer_xe_2013.1.117/mkl/lib/*/ is a folder with the 41 libmkl** files.

Be aware that the export command is temporary, will reset to
/usr/lib:/lib:/usr/local/lib etc. when you exit the terminal.

Ref. #5

Probably wrong. I have XE_2011, and I don't think they change that much in XE_2013.
So it should be "/opt/intel/composer_xe_2013.1.117/mkl/lib/ia32"
Or "/opt/intel/mkl/lib/ia32" ( If you have a 32bits (i686) OS.)


loyalnepali 05-27-2013 02:18 PM

Again problem
I think the intel compiler is not installed properly.How do you know whether it is installed well or not? please tell me how can I uninstall and install again.The solution didnt work. I tried $ which ifort. It displayed nothing. Does it mean it is not installed but when I try to install it says that I have already installed.

knudfl 05-27-2013 04:36 PM

# 7 .

$ which ifort
Only an executable that is in your PATH will be shown.

Which version of gamess did you download ? > > >
GAMESS version May 1, 2012 R2 for 32 bit (x86 compatible) ... Linux
GAMESS version May 1, 2012 R2 for 64 bit (x86_64 compatible)Linux with gnu compilers
GAMESS version May 1, 2012 R2 for 64 bit IA64/x86_64 Linux with Intel compilers


loyalnepali 05-27-2013 07:40 PM

2 Attachment(s)
The first one.As my linux system is 32 bit.I had to use 32 bit gamess.I have sent you some photos of path of mkl so that I think you can suggest me.For gamess,it was configured,successfully completed ddi and compddi.But when I tried linking error appeared.

All times are GMT -5. The time now is 04:06 AM.