LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-04-2003, 09:13 PM   #1
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
A way to make PAM to run in silence


Ok, I'm having some problem with PAM because that thing is filling up my log with useless msg every time CRON start jobs. The problem is that I have some cron jobs executed every 5 or 10 min.

So my logs look like :
Aug 4 20:55:01 router PAM_unix[19674]: (cron) session opened for user root by (uid=0)
Aug 4 20:55:01 router /USR/SBIN/CRON[19675]: (root) CMD (/etc/init.d/ipupdate >> /dev/null)
Aug 4 20:55:04 router PAM_unix[19674]: (cron) session closed for user root
Aug 4 21:00:01 router PAM_unix[19728]: (cron) session opened for user root by (uid=0)
Aug 4 21:00:01 router /USR/SBIN/CRON[19729]: (root) CMD (/etc/init.d/ipupdate >> /dev/null)
Aug 4 21:00:02 router PAM_unix[19728]: (cron) session closed for user root
Aug 4 21:05:01 router PAM_unix[19788]: (cron) session opened for user root by (uid=0)
Aug 4 21:05:01 router /USR/SBIN/CRON[19789]: (root) CMD (/etc/init.d/ipupdate >> /dev/null)
Aug 4 21:05:02 router PAM_unix[19788]: (cron) session closed for user root
Aug 4 21:10:01 router PAM_unix[19822]: (cron) session opened for user root by (uid=0)
Aug 4 21:10:01 router /USR/SBIN/CRON[19823]: (root) CMD (/etc/init.d/ipupdate >> /dev/null)
Aug 4 21:10:02 router PAM_unix[19822]: (cron) session closed for user root



Well, pretty annoying! Is there a way to shut up PAM or just force it to run in quiet mode?
 
Old 08-04-2003, 10:15 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
" Is there a way to shut up PAM or just force it to run in quiet mode?"

If there is a way it is probably a configuration parameter in /etc/pam.conf or perhaps /etc/pam.d/other
 
Old 08-04-2003, 10:44 PM   #3
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 46
I already read all the PAM docu on tldp and there's only options to INCREASE logging, not too decrease it.
 
Old 08-05-2003, 03:08 PM   #4
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
You might try changing /etc/syslog.conf to not log the PAM messages.

For example if PAM classifies the messages as info then you could have a line in /etc/syslog.conf that says:
*.info /dev/null
This will eliminate all info messages from any program.

Similarly if PAM classifies the messages as notice then you could have a line in /etc/sylogd.conf that says:
*.notice /dev/null
 
Old 08-05-2003, 07:22 PM   #5
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 46
well it's not a good solution since I need some info or notice msg that are not coming from PAM. But thanks you anyways I think it will end like this soon, I'm pretty tired of all these useless msg.

There's no ways to gently ask PAM to stop logging sucessful action, as example?
 
Old 08-05-2003, 08:43 PM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
You might try changing /etc/syslog.conf to not log the PAM messages.
Bad, damn bad suggestion. PAM and other access methods' logging is there for a reason. Half_Elf, if you got problems *reading* your (logrotated) logs, try to pull them tru a logparser like Logsurfer or Logwatch to shake off the crud else pipe them tru a filter, maybe something like this: http://www.linuxquestions.org/questi...984#post410984
 
Old 08-05-2003, 10:29 PM   #7
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Original Poster
Rep: Reputation: 46
unSpawn: well, habitually, I use tail -f to keep an eye on my log. I suppose I'll have to learn perl to code something to show me everything BUT these annoying PAM msg
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changelog silence davidsrsb Slackware 8 03-28-2005 08:35 AM
...and then there was silence ThreeGreen Linux - Hardware 7 12-14-2004 02:23 PM
vsftpd + pam + virtual users - Pam cannot load database file. mdkelly069 Linux - Networking 3 09-23-2004 12:07 AM
The sound of silence... Q-collective Linux - Software 14 07-27-2003 09:17 PM
the module is there, but the silence goes on kev0lush Slackware 6 02-27-2003 01:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration