-   Linux - General (
-   -   2.6-test9 compile problem - undefined reference to `ide_hwifs' (

saint 11-20-2003 09:23 AM

2.6-test9 compile problem - undefined reference to `ide_hwifs'
I tried to compile the linux-2.6.0-test9 kernel on a Red Hat 9 system. The compile gave an error. I am posting the error message below. Any help would be very welcome.


  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o(.text+0x384c2): In function `ide_match_hwif':
drivers/ide/setup-pci.c:59: undefined reference to `ide_hwifs'
drivers/built-in.o(.text+0x384c8):drivers/ide/setup-pci.c:59: undefined reference to `ide_hwifs'
drivers/built-in.o(.text+0x384f0):drivers/ide/setup-pci.c:71: undefined reference to `ide_hwifs'


drivers/built-in.o(.text+0x399b0): In function `__ide_dma_off_quietly':
drivers/ide/ide-dma.c:507: undefined reference to `ide_toggle_bounce'
drivers/built-in.o(.text+0x39a70): In function `__ide_dma_on':
drivers/ide/ide-dma.c:568: undefined reference to `ide_toggle_bounce'
drivers/built-in.o(.text+0x39bc7): In function `__ide_dma_read':
drivers/ide/ide-dma.c:659: undefined reference to `ide_execute_command'
drivers/built-in.o(.text+0x39c67): In function `__ide_dma_write':
drivers/ide/ide-dma.c:690: undefined reference to `ide_execute_command'
drivers/built-in.o(.text+0x39ed2): In function `__ide_dma_verbose':
drivers/ide/ide-dma.c:825: undefined reference to `eighty_ninty_three'
make: *** [.tmp_vmlinux1] Error 1

Any help on what I am missing ?

schatoor 11-20-2003 10:22 AM

Hi there.
First, what version of gcc do you have. Seing that you use RH 9, which is an modern distro, gcc should be fine.
Another thing could be that your ram is not good any more. memtest86 is an utility that test's your ram. I would recomend you try it.

saint 11-20-2003 10:39 AM

Thanks for your hints. however, the compile itself fails. I cannot build bzImage itself, so I think I am not setting some of the options correctly.
My gcc is gcc (GCC) 3.2.2 20030222

schatoor 11-20-2003 12:17 PM

Yes I got that. Generally, when an kernel compilation fails, it can be an indication that the ram is bad, because the kernel compilation process makes extensive use of the ram.
The thing is, the kernel guy's make absolutely sure the code is alright. Under no circumstances should a kernel compilation fail. If it does, there is something seriously wrong.
And as I thought, your gcc version is very new. I really think you should suspect your ram.

saint 11-20-2003 02:40 PM

I think I had made some mistakes in making my selections. I took the original config file of my RedHat from "/boot/config-2.4.20-8" and copied it to the source directory as .config. Then I ran make oldconfig. It asked a few question and then when I recompiled it, everything went smoothly.

So, I guess I made some wrong choices somewhere. The modules are still being compiled, hopefully I should not get any errors. Thanks for your help.

schatoor 11-20-2003 04:53 PM

Okey, my bad. Sorry.

All times are GMT -5. The time now is 04:13 PM.