-   Linux - General (
-   -   2.6.6 Kernel won't recognize any file systems after recompile (

justinmc 06-12-2004 05:52 PM

2.6.6 Kernel won't recognize any file systems after recompile
I'm running a Slack box, with slack's 2.6.6 generic testing kernel installed, and I want to just do a regular kernel upgrade to 2.6.6, as I have an Athlon64, and I want to see how the code for the x86_64 CPUs works.

So I installed 2.6.6. When I rebooted, I get an error telling me that not only is the ext3 fs not supported by the kernel, neither is the ntfs (and, as I find out later, neither is iso, or udf, or basically anything). So I think ok, I'm an idiot, I forgot to enable ext3 (et. al) options (I chose to ignore the fact that /root was mounted as ext3). Well, I look at my config file, and, as it turns out, I'm not as stupid as I think - everything is enabled correctly.

to truncate a much longer and boring story, many attempts later, I'm still having no luck, and having to revert back to slack's 2.6.6, which I don't like doing. The kernel compiles fine on my 2nd comp. See below for stuff I've tried

Stuff I've tried already:
1. Re-compiling on computer 1 (Athlon64 3400+) with K8 (Athlon64) and with i386 , neither of which worked

2. Compiling on computer 2 (Athlon T-Bird 1.40 with K7 (Athlon) and with K8m, and copying bzImage and to computer 1. This didn't work, which leads me to think there's maybe a compile error in computer 1, somewhere.

3. Compiled on computer 2, physically removed hard drive, booted from said hard drive, copied all files from said hard drive to computer 1, then booted from computer 1 again. This works, but its a pain in the arse, and I already had to do this for the SATA to work (another long story). I'd like to avoid it if possible, because then I have to recompile computer 2's kernel again.

Where Stuff Is:
/boot/ Symlink to /boot/

/boot/vmlinuz: Symlink to /boot/bzImage-2.6.6-x84_64

/boot/config: Symlink to /boot/config--2.6.6-x84_64

/usr/src/linux: Symlink to /usr/src/linux-2.6.6

Sorry bout the long post, but too much info is better than too little, eh?

So any ideas?

And yes, ext3 is compiled directly into the kernel, as is ntfs, as is iso.

jailbait 06-12-2004 08:54 PM

"And yes, ext3 is compiled directly into the kernel, as is ntfs, as is iso."

Is your new kernel using the old initrd (or any initrd)? If so there is probably a conflict between what the initrd says to load and what is compiled into the kernel.

Be prepared. Create a LifeBoat CD.

Steve Stites

justinmc 06-14-2004 06:32 PM

I'm not using any initrd atm...I'll try using one and see what happens

All times are GMT -5. The time now is 06:31 AM.