-   Linux - General (
-   -   “User’s $HOME/.dmrc” file is being ignored. (

freezykid 10-05-2007 12:26 AM

“User’s $HOME/.dmrc” file is being ignored.
hey this is the first time i am posting here,

I got the following problem after upgrading my rhel from 4 to 5,at the login...

“User’s $HOME/.dmrc” file is being ignored. This prevents the default session and language from being saved. File should be owned by user and have 644 permission. User $HOME directory must be owned by user and not writable by other users

i tried finding solution, one suggested to run the following on ComLine,

chmod 644 ~/.dmrc
>>> but got following msg when tried it...
chmod: cannot access `/home/<user_name>/.dmrc': No such file or directory

to no surprises i got no '.dmrc' file in my home directory...

Please help...

gilead 10-05-2007 01:22 AM

Have you tried creating the file?

touch ~/.dmrc && chmod -c 0644 ~/.dmrc
It's odd that it hasn't created it for you. What are the permissions on your home directory?

freezykid 10-05-2007 02:07 AM


the code did create the .dmrc file, but how does it help in solving the problem...

freezykid 10-05-2007 02:42 AM

I solved the problem by running the follwing...

>>>as root
chown <myusername> /home/<myusername>
>>>as <myusername>
chmod 700 /home/<myusername>

the msg is not coming anymore at the login...

Thanks for your reply, time and support...
Will get back in case of any other problem...

reffu 05-12-2009 08:35 PM

Thanks that really savd me from having to reinstall ubuntu.

jamwaffles 05-23-2009 11:15 AM


Originally Posted by reffu (Post 3538851)
Thanks that really savd me from having to reinstall ubuntu.

Same lol. i was having the same problems and now i think its fixed. One more to a truly brilliant forum


bedo 07-09-2013 01:55 PM

thx guys, you saved my day

hamdiozdemir 07-16-2014 03:52 AM

User’s $HOME/.dmrc” file is being ignored.
Hello there,

I had the same error.
My scenerio;
I have two user

When i log in with root username,i have this error.
But when i log in with oracle username,everything works fine.

After having problem i googled it and i wrote from terminal as recommended in here;

In my case;

--I logged in with root username and did write following commands in terminal

chown oracle:oracle /home/oracle/.dmrc
chmod 644 /home/username/.dmrc
chown oracle:oracle /home/oracle
chmod 755 /home/oracle

--I do not know if any wrong step i took while writing these commands from

--On the other hand when i try to find /.dmrc file i could not find it out.

---There is a file named oracle in my home path. I checked sub-folders. How can i exactly where it is?

All times are GMT -5. The time now is 09:34 AM.