-   Linux - General (
-   -   [dump,restore] system => kernel panic? (

bdp 12-13-2003 10:30 PM

[dump,restore] system => kernel panic?
hi all,

hda1 holds /boot
hda2 holds everything else.
hda3 holds swap

everything was working so well i dumped hda2, then tried to test it using restore.

the dump command used was: dump -0f /path/to/hda2.dump /dev/hda2 .
then, after doing: mkfs -t ext3 /dev/hda2,
the restore command used was: restore -rf /path/to/hda2.dump

upon boot, it complains as follows:
Creating root device
mkrootdev: label / not found
Mounting root filesystem
mount: error 2 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 128k freed
Kernel panic: No init found. Try passing init= option to kernel.

the grub.conf section i typically boot to is:
title Red Hat Linux (2.4.22-openmosix-2)
root (hd0,0)
kernel /vmlinuz-2.4.22-openmosix-2 ro root=LABEL=/
initrd /initrd-2..22-openmosix-2.img

but grub.conf sits on hda1, which was not modified recently.
fdisk -l looks good for hd1 and hda2: both id 83. fsck says hda2 is clean.
cd'ing around hda2 looks good, i don't notice anything different with the filesystem.

anybody know what i'm missing? a clean setup is hiding in hda2 somewhere...

thanks if any ideas, - bp

js42 01-12-2004 06:17 AM


I had the same problem migrating a Redhat 9.0 instalation from one harddisk to another.

The solution was to assign labels to the partitions. Redhat uses the volume labels of ext3 for the root option and in /etc/fstab. I had not used the -L option in the mke2fs call.

# tune2fs -L "/boot" /dev/hda1
# tune2fs -L "/" /dev/hda2

solved my problem.


bdp 01-12-2004 09:19 PM

agreed, i used e2label for partition labelling. including the labelling step, dump appears to be superior to dd for partition moving and system backup since partitions do not need to be held at constant size or require resizing after restoration to dissimilar partition sizes.

thx for the feedback.

All times are GMT -5. The time now is 11:38 PM.