-   Linux - Games (
-   -   "Xlib: extension "XFree86-DRI" missing on display ":0.0"." (

zaps 01-13-2005 07:55 AM

"Xlib: extension "XFree86-DRI" missing on display ":0.0"."

I have cedega and some games works but others not..

Error is this:

"Xlib: extension "XFree86-DRI" missing on display ":0.0"."

What I have to do? I have DEBIAN and Geforce 2 mx/mx400.


qwijibow 01-13-2005 08:00 AM

it seems to be that you have not correctly installed the nvidia drivers ?

are you using Xorg or XFree86 ?
did you install the Nvidia Drivers from ?
did you edit the /etc/X11/xorg.conf / XFree86.conf as instructed in the documentation ?

Range77 01-13-2005 08:31 AM

I had this problem as well, just reinstall the nvidia drivers, it worked on Mandrake 10.1

zaps 01-13-2005 11:43 AM

OKay BUT.. I downloaded the drivers but Nvidia drivers aren't for i386/x86 system..

Where could i get those drivers? :(((

Genesee 01-13-2005 12:16 PM

try "Linux IA32"

zaps 01-13-2005 03:14 PM

i tried it but not.. it isnt compatible with debian or something!!! :(

MNKyDeth 01-15-2005 01:11 AM

Typically I have noticed some distro's have nvidia drivers in there repos. Try using apt-get or synaptic wich should be available or already installed for your debian distro. Do a search for nvidia and it should list some files. If it does I would grab nvidia-glx and nvidia-settings. There maybe others you need to get aswell but I am not for sure as I havn't used a debian based distro.

h3o 04-03-2005 06:28 AM


im using debian, and i get the same msg, i havent tried reinstalling the drivers yet, but, when i first installed the drivers i did have a few difficulties, and i found that what i had to do was actaully find the kernel module that the nvidia drivers built (nvidia.ko) and copy/move that to my kernel modules directory (/lib/modules/2.X.X/kernel) i then manually inserted the module into the kernel using modconf, otherwise modprobe should work, im not sure on the usage tho, check the man pages. Its useful to set up yr init to start up without yr Xorg or Xfree86 when doing this stuff, i did it by removing gdm from runlevel 3, and setting that to the start up runlevel, i dunno why debian doesnt seem to have that by default.

gnuzilla 04-02-2006 04:15 PM

"Xlib: extension "XFree86-DRI" missing on display ":0.0"."
the reason debian doesnt include the official nvidia or ati drivers by default is because they are closed source proprietary drivers. Being closed source is aginst debian's policy for inclusion in official ISOs

althou i personaly im not against them creating some DAMN good packages in the non-free repositories (packages with LESS bugs then the corrisponding installers)

dogatemycomputer 05-14-2007 03:07 PM

Kubuntu / Ubuntu
I had this problem with Kubuntu which took me some time to figure out. It turned out to be something really dumb.

"Xlib: extension "XFree86-DRI" missing on display ":0.0"."

You see.. Ubuntu and Kubuntu use a Restricted-Driver manager to load/unload non-FOSS drivers. Even if they are installed and specified in the xorg.conf does not mean they'll load properly. If you use GNome as your Windows Manager then you can load the Restricted Driver's Manager from the System or Preference's menu (I can't remember which).

Ironically.. If you use Kubuntu then this particular menu item is missing. In order to load the Restricted Driver Manager in Kubuntu then..

sudo /usr/bin/restricted-manager

If you check the box and reboot then it should change this message:

"Xlib: extension "XFree86-DRI" missing on display ":0.0"."

To this one:

OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X600 PRO
OpenGL version string: 2.0.6334 (8.34.8)

If you are running glxgears and getting 400-600 frames per second using either Ubuntu or Kubuntu or your video playback seems a bit slow then this may also solve your problem. This also corrected my problem getting mplayer to play multiple videos in multiple windows on multiple monitors simultaneously without a loss in quality.

Best Regards,

All times are GMT -5. The time now is 01:26 AM.