-   Linux - Games (
-   -   Wow error in FC8 x86_64 .. using wine (

alex.xzy 04-21-2008 03:39 AM

Wow error in FC8 x86_64 .. using wine
I am using now fedora core 8 .... having a fresh install of it.
Everything works fine with a bit of tuning. However, I can;t get Wine to work fine.
I have the install from Windows of WOW (World of Warcraft), which should work in linux too. I tried with a live CD distribution including wine (PCLinuxOS) and it works great.
However, in FC8 I keep getting an error code:

[alex.xzy@localhost World of Warcraft]$ wine Wow.exe -opengl
err:module:attach_process_dlls "DivxDecoder.dll" failed to initialize, aborting
err:module:LdrInitializeThunk Main exe initialization for L"E:\\games\\World of Warcraft\\Wow.exe" failed, status c0000005
then, I thought to try to repair the file, running Repair.exe:

[alex.xzy@localhost World of Warcraft]$ wine Repair.exe
wine: Unhandled page fault on execute access to 0x00468c18 at address 0x468c18 (thread 0009), starting debugger...
Unhandled exception: page fault on execute access to 0x00468c18 in 32-bit code (0x00468c18).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:00468c18 ESP:0032ff0c EBP:0032ffe8 EFLAGS:00010246( - 00 -RIZP1)
EAX:00000000 EBX:7ee8ca64 ECX:5da95a15 EDX:00000000
ESI:7ffdf000 EDI:00468c18
Stack dump:
0x0032ff0c: 7ee40d07 7ffdf000 00000000 00000000
0x0032ff1c: 00000000 00000000 00000000 00000000
0x0032ff2c: ffffffff 7edf9754 7ee0f120 7ee8ca64
0x0032ff3c: 7ffdf000 00000018 0032ffe8 cb4396e8
0x0032ff4c: 66a4f615 00000000 00000000 00000000
0x0032ff5c: 00000000 00000000 00000000 00000000
=>1 0x00468c18 EntryPoint() in repair (0x0032ffe8)
2 0xf7eab817 (0x00000000)
0x00468c18 EntryPoint in repair: pushl $0x60
Module Address Debug info Name (81 modules)
ELF 1d7000- 1da000 Deferred
ELF 1dc000- 1e5000 Deferred
ELF 1ee000- 27a000 Deferred
PE 400000- 4b7000 Export repair
PE 400000- 4b7000 Export repair
ELF 83a000- 83c000 Deferred
ELF 83e000- 841000 Deferred
ELF 845000- 862000 Deferred
ELF 864000- 9bd000 Deferred
ELF 9bf000- 9c4000 Deferred
ELF 9c6000- 9ef000 Deferred
ELF 9f1000- a0a000 Deferred
ELF a0c000- a0f000 Deferred
ELF ade000- afa000 Deferred
ELF b29000- b32000 Deferred
ELF b34000- b37000 Deferred
ELF b47000- b4d000 Deferred
ELF b55000- b69000 Deferred
ELF b94000- b97000 Deferred
ELF b9b000- c97000 Deferred
ELF cab000- cda000 Deferred
ELF d0f000- d30000 Deferred
ELF d32000- d37000 Deferred
ELF d83000- d96000 Deferred
ELF dda000- de4000 Deferred
ELF de6000- df6000 Deferred
ELF 380e000- 3817000 Deferred
ELF 3819000- 3833000 Deferred
ELF 65d2000- 65eb000 Deferred
ELF 7aa5000- 7aac000 Deferred
ELF 7b6f000- 7b9d000 Deferred
ELF 7bb7000- 7bd2000 Deferred
ELF 7e42000- 7ed5000 Deferred
ELF 7ed7000- 7efd000 Deferred
ELF 7bf00000-7bf03000 Deferred <wine-loader>
ELF 7de50000-7de54000 Deferred
ELF 7de54000-7dea9000 Deferred
ELF 7defa000-7df77000 Deferred
ELF 7e05e000-7e096000 Deferred
ELF 7e0ed000-7e120000 Deferred uxtheme<elf>
\-PE 7e0f0000-7e120000 \ uxtheme
ELF 7e2bc000-7e352000 Deferred winex11<elf>
\-PE 7e2d0000-7e352000 \ winex11
ELF 7e464000-7e514000 Deferred ole32<elf>
\-PE 7e470000-7e514000 \ ole32
ELF 7e514000-7e54b000 Deferred winspool<elf>
\-PE 7e520000-7e54b000 \ winspool
ELF 7e54b000-7e5f6000 Deferred comdlg32<elf>
\-PE 7e550000-7e5f6000 \ comdlg32
ELF 7e5f6000-7e65a000 Deferred rpcrt4<elf>
\-PE 7e600000-7e65a000 \ rpcrt4
ELF 7e65a000-7e6aa000 Deferred wininet<elf>
\-PE 7e660000-7e6aa000 \ wininet
ELF 7e6aa000-7e6d8000 Deferred ws2_32<elf>
\-PE 7e6b0000-7e6d8000 \ ws2_32
ELF 7e6ec000-7e6f1000 Deferred
ELF 7e6f1000-7e712000 Deferred mpr<elf>
\-PE 7e700000-7e712000 \ mpr
ELF 7e712000-7e731000 Deferred iphlpapi<elf>
\-PE 7e720000-7e731000 \ iphlpapi
ELF 7e731000-7e78e000 Deferred shlwapi<elf>
\-PE 7e740000-7e78e000 \ shlwapi
ELF 7e78e000-7e8a2000 Deferred shell32<elf>
\-PE 7e7a0000-7e8a2000 \ shell32
ELF 7e8a2000-7e8b6000 Deferred lz32<elf>
\-PE 7e8b0000-7e8b6000 \ lz32
ELF 7e8b6000-7e90b000 Deferred advapi32<elf>
\-PE 7e8c0000-7e90b000 \ advapi32
ELF 7e90b000-7e9af000 Deferred gdi32<elf>
\-PE 7e920000-7e9af000 \ gdi32
ELF 7e9af000-7eb05000 Deferred user32<elf>
\-PE 7e9d0000-7eb05000 \ user32
ELF 7eb05000-7ebcd000 Deferred comctl32<elf>
\-PE 7eb10000-7ebcd000 \ comctl32
ELF 7edcd000-7ef06000 Deferred kernel32<elf>
\-PE 7edf0000-7ef06000 \ kernel32
ELF 7ef3b000-7ef55000 Deferred version<elf>
\-PE 7ef40000-7ef55000 \ version
ELF 7ef55000-7f000000 Deferred ntdll<elf>
\-PE 7ef70000-7f000000 \ ntdll
ELF f7d20000-f7d2c000 Deferred
process tid prio (all id:s are in hex)
00000008 (D) E:\games\World of Warcraft\Repair.exe
00000009 0 <==
00000016 0
00000014 0
00000010 0
0000000e 0
0000000d 0
00000015 0
00000013 0
00000012 0
=>1 0x00468c18 EntryPoint() in repair (0x0032ffe8)
2 0xf7eab817 (0x00000000)
I hope someone can help me. Usually I got on this forum all the answeres I needed, but this problem it seems to be a weird one.

Thanks alot for anyone could lay a hand on my problem.

Hammett 04-21-2008 12:16 PM

Try donwloading the divx library and copy it to your wine/windows/system32 folder.
You can find the dll here

alex.xzy 04-22-2008 01:43 AM

Thank you for the reply, but I tried it before ...
putting divxdecoder.dll in windows, windows\system32 and windows\system folder and it didn't solved the problem ...
However, I erased divxdecoder from the game folder and now it works

All times are GMT -5. The time now is 08:45 PM.