LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   WoW crashes in user selection screen under wine (https://www.linuxquestions.org/questions/linux-games-33/wow-crashes-in-user-selection-screen-under-wine-366977/)

userini 09-25-2005 04:23 PM

WoW crashes in user selection screen under wine
 
Hi,

I've been struggling with getting World of Warcraft to run smoothly under FC4 and wine for several days, with various progress. Under 1.6, I was actually able to get into the game, but I would get horrible 5fps performance, so I decided to switch from the proprietary ATI drivers to Livna driver rpms. However, 1.7 was released which broke my entire WoW setup, so that I had to recopy the entire WoW directory after patching from my Windows machine.

But anyway, that's in the past...

Right now, I have the following problem:
I've installed Wine 20050830 from CVS, and I'm still running the Livna ATI drivers. When I run WoW (wine WoW.exe -opengl), I can login, but at the character selection screen, the entire (!) PC freezes after a couple of seconds. I can't kill X using Ctrl-Alt-Backspace, and random button-pounding does not seem to alleviate the problem either. I am forced to reboot the PC.

I have little to no clue why this happens, except for the possible reason of having two drivers installed at the same time - I installed the Livna rpms on top of the old proprietary ATI install, since I couldn't figure out how to uninstall them after installing them from a binary. However, I can run UT2K4 perfectly, so it seems to me that 3D acceleration isn't the problem.

I am running this on a Athlon 3200, 1 gig of ram, Radeon 9800 Pro.

Any assistance with this issue would be GREATLY appreciated :)

P.S. As for the cop-out of getting Cedega, I am not considering this at the moment, since I don't want to add $5 to my monthly $15 WoW bill, especially since I could in the extreme case switch to dual-booting.

lafrad 10-02-2005 04:36 PM

I am having the exact same problem, similar software setup.
I Copied WoW over from my desktop, and proceeded to run "wine WoW.exe" or "wine WoW.exe -opengl". I am able to log in, select my character, and start loading my way in. As SOON as the progress bar reaches 100%, it completely freezes my whole notebook. No keyboard breaks can kill it, and pushing the power button quickly doesnt even invoke the shutdown response from the kernel. I have to do the "4 second" hold of the power button to get the computer back....

My hardware is:
Dell Inspiron 8200 (notebook)
2.0 ghz
640 mb Ram
ATI Radeon Mobility 9000 64mb

FC4,
Kernel 2.6.13
Wine 20050930

userini 10-02-2005 08:00 PM

I've pretty much given up trying to get it to work - I've tried running it under different versions of Wine, but no avail. At the same time, I doubt that anyone can really offer help with the sparse debugging information of 'computer freezes up'.

Perhaps someone knows if Wine has a log that could be checked for info of operations prior to the crash? Maybe that could help me find something that explains what causes the crash to happen. I've checked the Wine documentation, although not too thorougly, but such a log doesn't seem to exist :(

lafrad 10-04-2005 07:37 AM

Well, I got it running successfully on my other computer...

P4 1.6 Ghz @ 2.0 Ghz.
Gigabyte 8KNXP
2GB DDR.
Audigy 2
GeForce FX5500 - 256MB

wine WoW.exe -opengl

Sound works, everything shows up correctly (no mini-map problems, no texture problems)
Its really slow. The windows install on a different hard drive, same hardware (ATI 8500 graphics card) is MUCH smoother. Only problem is, I can't get my ATI 8500 to properly work in xorg, as it will run for about 5 minutes, then FREEZE, with the mouse being able to move, but the rest of the system is completely unresponsive.

Ah well. Maybe its time to invest a little bit in some new hardware. The FX5500 is a notoriously bad card for any modern game, and the ATI has been in overclocked machines (and has been overclocked) and in constant use for almost 5 years....

Almost forgot. I used this RPM:
http://forums.fedoraforum.org/showth...highlight=wine

Adriaan Nikken 07-09-2007 05:49 PM

wow freeze
 
Yet another wow freeze here.
I did regress to the 9.30 version of wine because someone said that is part of the problem. Bough a bigger ram (went to a gig)
I am on a HP zv5000 running ubuntu. Mine seems to freeze on the reboot screen before it can download the new patch. I am new with wow, and somewhat with Linux


All times are GMT -5. The time now is 11:16 AM.