-   Linux - Games (
-   -   World of Warcraft - No Visuals, just Sound (

Fergatron 03-30-2008 01:34 AM

World of Warcraft - No Visuals, just Sound
I've been on a long gruling journey trying to get WoW working on my Fedora 8 distro. I'm pretty new to linux so I don't understand ALL the video aspects of getting Wine/WoW to work together. After some research this is what I've done:
  • Installed the latest version of wine
  • Installed World of Warcraft, then installed Burning Crusade, then patched 2.4.
  • Upgraded my video drivers (nVidia GeForce 8600) using YUM install kmod-nvidia
At this point the launcher comes up just fine, before installing kmod-nvidia I was able to see the login screen, but it was terrbily slow - no way I could play the game with that kind of speed. After I upgraded the video card, I rebooted the computer and when I run WoW I can hear the music, but all I see is a pixelated block that is supposed to be my mouse.

So; I also saw that just about 80/20 of folks posting about this mentioned "opengl". I changed the to support opengl and I got some 3d accelerator error. It would seem that d3d gets me further. Can anyone shed some light Please?

Oh; I'm running an AMD 64, 2GB RAM, nVidia GeForce 8600.

Simon Bridge 03-30-2008 06:21 PM


[snip] then patched 2.4. [snip] I got some 3d accelerator error. It would seem that d3d gets me further.
You are light on details here.

Compare what you did with:
... article seems a bit out of date, but cannot confirm.

nvidia cards can give trouble though - so look to your xorg.conf options.

Jayla 03-31-2008 12:42 PM

i had wow working completely fine

since upgrading to wow 2.4 patch its totally screwed it up, so i have to boot windows to play it, till I can find a solution

would be interested to know if any others have this issue

Fergatron 03-31-2008 08:37 PM

I finally got WoW working on my machine. I basically followed the same instructions from WoWWiki and a bunch of other sites that instructed the same thing. The only thing I did different was get the video drivers from nVidia's web site. The funny thing is just about everyone advised not to get the drivers from the manufacturers site, but like you said - these tutorials are out-dated.

I have a new problem now. I got the video working, but my sound doesn't work anymore. I have Wine's audio set to the defaults - and the game worked three times with sound, but after that it doesn't work anymore. Any ideas? Thanks.

Jayla 04-01-2008 04:13 PM

Fergatron, are you running any other sound enabled apps such as amarok/teamspeak etc etc?

its possible you need to run wow with AOSS so the apps share sound

All times are GMT -5. The time now is 01:46 AM.