LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 10-26-2005, 09:54 AM   #1
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
What is direct rendering and how to enable it.


I have download and install a linux-based game named: "Boson"
Someone on this forum have introduced this game but I cannot remember his name or the web address right now?

When I launch this game it said direct rendering is not enbale. The game will be very slow. And it asked me to enable direct rendering.
When the game is load, it was too slow that my mouse cannot move, and I have no choices but exit it.
How to fix this please. I think boson is not a huge game and eventhogh my PC is slow, it mustn't be too slow like this.!!!
 
Old 10-26-2005, 10:33 AM   #2
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
In a nutshell: DRI includes card/chipset-specific commands which enables the X server to talk directly to the video card - natively - without having to resort to a VESA compatibility mode. That's not exactly accurate but a fair brief explanation.

If you really want to learn more about it check out http://dri.freedesktop.org/wiki/

With that said: to enable DRI you generally have to compile the kernel module for the video chipset in your computer, then download and install (or compile and install) the specific X server for your video chipset/video card.

Could you post some specifics for your computer (post some specifications!) and we'll point you at a good HowTo specific to your chipset.

--Kim
 
Old 10-30-2005, 10:15 PM   #3
shazam75
Member
 
Registered: Oct 2004
Location: Australia, Brisbane
Distribution: Gentoo
Posts: 296

Rep: Reputation: 30
Answer: YOU do not have 3d acceleration (3D Card)

regards
 
Old 10-30-2005, 11:19 PM   #4
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
shazam75,

How can you know that when he hasn't posted his configuration?
 
Old 10-31-2005, 12:10 AM   #5
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 57
Quote:
Originally posted by KimVette
shazam75,

How can you know that when he hasn't posted his configuration?
KimVette: Oh can't you read minds yet?

TruongAn: Could you post the output of these two commands?
Code:
lspci
cat /etc/X11/xorg.conf | grep -i driver
Then we'll know what kind of video card you have and what driver X.org is using
 
Old 10-31-2005, 12:17 AM   #6
shazam75
Member
 
Registered: Oct 2004
Location: Australia, Brisbane
Distribution: Gentoo
Posts: 296

Rep: Reputation: 30
Hi Kim

It sounds like he does not have 3D acceleration.

Regards
Shelton.
 
Old 10-31-2005, 03:49 AM   #7
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Original Poster
Rep: Reputation: 33
Yes, I don't have 3D acceleration, Do you have any suggest to make the game play???
 
Old 10-31-2005, 11:27 AM   #8
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
How about posting the output of the commands cs-cam gave so someone can help you?
You'll probably need to run /sbin/lspci rather than just lspci though...
 
Old 11-01-2005, 05:03 AM   #9
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Original Poster
Rep: Reputation: 33
I don't think you need my lspci output because I used onboard video card.
However I posted it here in order to seek for help
Code:
00:00.0 Host bridge: Intel Corporation 82810E DC-133 GMCH [Graphics Memory Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E DC-133 CGC [Chipset Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio (rev 02)
01:00.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
And the cat /etc/X11/Xorg.conf | grep -i driver said:
[code ]
Driver "kbd"
Driver "mouse"
Driver "i810"
[/code]
So, what I have to do next?
 
Old 11-01-2005, 02:25 PM   #10
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
On the contrary, we now know that you indeed have a i810 graphics and you're using the correct driver. Try adding
Code:
Option "DRI"
to the Device section of xorg.conf, start X, then
Code:
cat /var/log/Xorg.0.log | grep dri
to see if it gets enabled. I have an older computer with a Blaster Banshee card that can't use DRI at higher resolutions and/or colour depths, maybe you need to lower the resolution. If so, you could create a script to start X at a lower resolution just for playing the game.
 
Old 11-03-2005, 07:46 AM   #11
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Original Poster
Rep: Reputation: 33
OK, I will try your suggestion later.
and by the way, I have 1152x864 resolution, 24-bit color depth and 75Hz refresh rate. Will it matter me?
 
Old 11-03-2005, 09:21 AM   #12
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
Yes, you have to use 16 bit colour for 3d acceleration. See the man page for i810
Code:
man i810
 
Old 11-04-2005, 08:32 AM   #13
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Original Poster
Rep: Reputation: 33
I hav done what you said the command
Code:
cat /var/log/Xorg0.log | grep dri
give that output (after I start the game)
Code:
        X.Org XInput driver : 0.4
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="X.Org Foundation"
(II) Loading /usr/X11R6/lib/modules/drivers/i810_drv.o
        ABI class: X.Org XInput driver, version 0.4
        ABI class: X.Org XInput driver, version 0.4
(II) Loading sub module "dri"
(II) LoadModule: "dri"
(II) Reloading /usr/X11R6/lib/modules/extensions/libdri.a
(II) UnloadModule: "dri"
(EE) I810: Failed to load module "dri" (once-only module, 0)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: node name is /dev/dri/card0
(II) I810(0): [drm] created "i810" driver at busid "pci:0000:00:01.0"
But the game still complain that Direct rendering is not enabled.
It run a little bit faster but still too slow to play.
Why?
 
Old 11-05-2005, 11:58 PM   #14
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 728
Blog Entries: 2

Rep: Reputation: 43
I think it's clear from the log that X was unble to load the dri module. I'd recommend reading the lines around the error message to see if they give more information about the failure. Did you set the colour depth to 16?
 
Old 11-06-2005, 01:53 AM   #15
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Original Poster
Rep: Reputation: 33
Quote:
Originally posted by ciotog
Did you set the colour depth to 16?
Yes I did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable direct rendering. dr_zayus69 Linux - Games 8 06-02-2008 05:10 PM
IM running Lycoris and I have the Game Pak how do I enable the Direct Rendering CaffeinatedGamer Linux - Newbie 14 05-31-2005 08:34 PM
change resolution + enable direct rendering ringmbr Linux - Hardware 0 05-20-2005 06:48 AM
Enable Direct Rendering rca36 Mandriva 12 03-29-2005 01:15 PM
how to enable direct rendering? marsques Slackware 2 09-07-2004 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 03:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration