-   Linux - Games (
-   -   Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0". (

badgerbox76 01-07-2006 09:08 PM

Video Card Nvidia Driver Xlib: extension "GLX" missing on display ":0.0".
I just downloaded americas army and wanted to install my video card driver becasue when i ran the glxinfo commmand i found the rendering was off so i followed the instructions from this site and when i rebooted my box and ran the command this is what i got. :( what should i do?

glxinfo | grep direct
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".

tuxdev 01-08-2006 03:56 PM

are you using the "nv" or "nvidia" driver in the video section of your xorg.conf?

badgerbox76 01-08-2006 04:37 PM

nv i will now try nvidia insted

badgerbox76 01-08-2006 05:41 PM

no luck with changing nv to nvidia the system just would not start x so i had to us my back up xorg.conf to start my system. What to do now?

gilead 01-08-2006 05:49 PM

What error (if any) did you get on the screen when you tried to start the gui with the nvidia driver? Can you look in /var/log/Xorg.0.log and see if there are any errors in that and post them here?

badgerbox76 01-08-2006 05:54 PM

Failed to start the X server (your graphical interface). it is likely that is is not set up correctly. Would you like to view the X server output to diagnose the problem?

it says Fatak server error: No screens found. so i exit the diagnose page and go to the command line were i enter startx then i get XIO: fatal IO error 104 (connection reset by peer on X server ":0.0" after o requests (0 known processed) with 0 events remaining.

here is another thread i started and i tryed to work through the problems with him aswell but i still could not get it to work. there is some information on that page about my problem so if you want to take a look i think it would help out:

gilead 01-08-2006 06:24 PM

If your problem is similar to one I was having with GLX, the following may help:

I'm not too optimistic though - it looks as though your other thread was quite thorough.

badgerbox76 01-08-2006 06:53 PM

ok i am going to read through your link, but before i do i want to tell you about my new error. when installing the driver i am geting this error.

ERROR: Unable to build the NVIDIA kernel module.

i guess any change is good change so mybe this new error is a good one :)

badgerbox76 01-09-2006 03:29 PM

any input about the Error?

gilead 01-09-2006 09:28 PM

Was there any other error text? Also, did it generate a log file, something like /var/log/nvidia-installer.log? Hopefully, there's something that will identify the problem.

mammlouk 01-10-2006 09:06 PM

One thing is to make sure that your kernel-source is installed and that it matches your current kernel. That is one thing that will cause a failure building the kernel module you need.

EnigmaX 01-11-2006 03:11 AM

The driver for nvidia needs to be installed, and once it is installed, you need to make sure the kernel module is loaded as well

Once you install the nvidia module, update the X conf file to use the driver nvidia, and then be SURE that nvidia is loaded at bootup, or load it yourself before X is loaded

badgerbox76 01-11-2006 04:21 PM

Thats what i want to do, install the video card driver and thats it but i just will not insall.

rshaw 01-11-2006 05:47 PM

Please do not post the same thread in more than one forum. Picking the most relevant forum and posting it once there makes it easier for other members to help you and keeps the discussion all in one place.

other is here:

All times are GMT -5. The time now is 12:59 PM.