LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   ut2003 glx visual problem (https://www.linuxquestions.org/questions/linux-games-33/ut2003-glx-visual-problem-212601/)

tutwabee 08-02-2004 03:21 PM

ut2003 glx visual problem
 
I have found some threads in LQ mentioning this problem but I can't seem to fix it. I tried updating my nvidia drivers and it doesn't help.

The problem is when I run Unreal Tournament 2003 or 2004 demo I get this error message:
Quote:

fcntl: Invalid argument
fcntl: Invalid argument
Couldn't set video mode: Couldn't find matching GLX visual


History:

Exiting due to error
Can someone please tell me what I am doing wrong? :confused:

tutwabee 08-02-2004 03:21 PM

almost forgot
 
Here is my xorg.conf file if its helps any:
Quote:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
FontPath "/etc/X11/artwiz-aleczapka-en-1.3/"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "SyncMaster"
DisplaySize 380 310
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 85.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Bikerpete 08-25-2004 02:16 PM

Re: almost forgot
 
Hello tutwabee and all the other tux-friends,

have you solved that problem?

I try to get UT2003 runnin´ , but after successful installation, all I get is the splash-screen and then - after a short while - the following message:

user@linux:~/bin> ut2003
fcntl: Invalid argument
fcntl: Invalid argument
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
OpenGL renderer relies on DXTC/S3TC support.

History:

Exiting due to error

Any idea how to solve that?
I got a ATI graphics card an I installed the newest driver from
ftp://ftp.suse.com/pub/suse/i386/sup...1/fglrx/3.11.1

Yes - I´m running Suse 9.1 ;-)

Can anybody help me ???

tutwabee 08-25-2004 06:15 PM

I did solve my problem. The problem was that I hadn't added the correct items in my xorg.conf file. You need to read the instructions file for your graphics card (mine was nvidia) to see what to add.

dezert_fox 08-25-2004 06:16 PM

Is the fglrx module loaded correctly? Check with lsmod.

trickykid 08-25-2004 06:52 PM

Moved: More suitable in Games.


All times are GMT -5. The time now is 08:47 AM.