LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 02-04-2008, 11:31 PM   #1
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Angry Unreal Tournament GOTY audio trouble


Just installed the classic Unreal Tournament Game of the Year Edition on my Dell e1405 (Ubuntu 7.10) laptop. It manages to run, but the sound is all choppy and stuff - making it virtually unplayable. Google shows that several people with the snd_hda_intel driver have had similar issues, but I haven't managed to find a fix. So I'm wondering if anyone has any ideas about things I can try to get the sound working properly on this game, which I would really love to be able to play on my laptop.
Code:
win32sux@candystore:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
win32sux@candystore:~$ lsmod | grep snd
snd_hda_intel         263712  2 
snd_pcm_oss            44672  0 
snd_mixer_oss          17664  1 snd_pcm_oss
snd_pcm                80388  2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy           4740  0 
snd_seq_oss            33152  0 
snd_seq_midi            9600  0 
snd_rawmidi            25728  1 snd_seq_midi
snd_seq_midi_event      8448  2 snd_seq_oss,snd_seq_midi
snd_seq                53232  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              24324  2 snd_pcm,snd_seq
snd_seq_device          9228  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54660  13 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               8800  1 snd
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
win32sux@candystore:~$
As always, any help would be greatly appreciated.
 
Old 02-05-2008, 12:51 AM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,352

Rep: Reputation: Disabled
You could try the generic sound driver. Normally this doesn't sound as good but it might be better than what you have at the moment.

You need to edit ~/.loki/ut/System/UnrealTournament.ini.
In the [Engine.Engine] section put a ; in front of the ALAudio line and make a new line AudioDevice=Audio.GenericAudioSubsystem:


[Engine.Engine]
...
;AudioDevice=ALAudio.ALAudioSubsystem
AudioDevice=Audio.GenericAudioSubsystem
...

Then try it out. I usually find that there is more hiss with this driver though.
 
Old 02-05-2008, 01:44 AM   #3
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Thanks for the reply! Okay, I made the change you suggested. Unfortunately, the sound didn't improve (it's still really choppy and with like a weird echo or something). An interesting thing, though, is that with AudioDevice=Audio.GenericAudioSubsystem the game moves much more naturally. When I set it back to AudioDevice=ALAudio.ALAudioSubsystem it's clear that everything moves WAY too fast. This includes the startup animation, the animated menu before entering a Rocket Arena, the game itself, etc.

I'm thinking I should leave it set on AudioDevice=Audio.GenericAudioSubsystem as you suggested, and maybe try experimenting by editing the [Audio.GenericAudioSubsystem] section, but I'm not sure. What do you think? It currently looks like this:
Code:
[Audio.GenericAudioSubsystem]
UseFilter=True
UseSurround=False
UseStereo=True
UseCDMusic=False
UseDigitalMusic=True
UseSpatial=False
UseReverb=False
Use3dHardware=False
LowSoundQuality=False
ReverseStereo=False
Latency=40
OutputRate=22050Hz
Channels=16
MusicVolume=192
SoundVolume=192
AmbientFactor=0.700000
DopplerSpeed=0.000000
Not sure if there's anything there worth tweaking.

EDIT: The excessive graphic speed problem seems to occur somewhat randomly. I've got it set on AudioDevice=Audio.GenericAudioSubsystem and it's happening again. In the game I have the game speed set to 50% and it's still insanely fast sometimes. If I knew for sure it was a separate issue I wouldn't even have brought it up here but I think it's related.

EDIT #2: Just tried playing with the True/False options in the [Audio.GenericAudioSubsystem] and didn't have any luck.

EDIT #3: If I set UseSound=False ini the [Engine.GameEngine] section, the graphics become super smooth, and the speed craziness disappears. Of course, there's no sound with that option set. =/

Last edited by win32sux; 02-05-2008 at 02:54 AM.
 
Old 02-05-2008, 02:56 AM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,352

Rep: Reputation: Disabled
The game speed is affected a lot by the cpu type. Speedstep is the main culprit and makes the game run at wrong speed.

You can get around this with using '-cpuspeed xxxx' in the startup command. You should set it to the high speed that your cpu runs at. I dont remember if you need to put '-cpuspeed=xxx' or without =.

I don't think changing the audio options will work. You could try maybe using one of the sound system wrappers for the game. I.e. like 'artsdsp UT' for kde or similar for alsa or gnome. You might need to edit the startup script for this.
 
Old 02-05-2008, 10:24 PM   #5
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Original Poster
Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
Thanks for the support, dive - I really appreciate it!

I've been messing around with this issue on and off since yesterday without much luck. Considering how non-critical this is, I'm gonna throw in the towel. I've still got the GNU/Linux desktop where I used to play this game before, so I'll probably just install it there to get my UT dose every once in a while. Having a properly-running UT on my laptop would be lovely, but it's not something I'm gonna lose any sleep over if it won't work. It's all good, and once again, thanks!
 
Old 02-05-2008, 10:35 PM   #6
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,352

Rep: Reputation: Disabled
No problem. Pity we couldn't get it working though, :/
 
Old 05-09-2008, 02:48 PM   #7
DalaiDakkar
LQ Newbie
 
Registered: May 2008
Posts: 1

Rep: Reputation: 0
Try this

I'm trying to get it run, until now I found this to make the sound clear but now it's kinda slow motion (only the sound)

$sudo apt-get install alsa-oss
run it as $aoss ut

Any clues on how to speed up sound?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unreal Tournament GOTY petri.airio Linux - Games 2 06-23-2007 06:32 AM
Unreal Tournament Goty khan123 Linux - Games 0 01-22-2006 03:06 PM
Unreal Tournament '99 GOTY Problems Schiz0 Linux - Games 4 01-02-2006 10:23 AM
Error from Unreal Tournament goty DarkNeo Linux - Games 6 10-18-2005 09:23 PM
Unreal Tournament GOTY jb17 Linux - Games 6 04-24-2005 11:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration