LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   Unreal Tournament 2003 install problems (https://www.linuxquestions.org/questions/linux-games-33/unreal-tournament-2003-install-problems-127368/)

thelenko 12-19-2003 04:37 PM

Unreal Tournament 2003 install problems
 
I found the .sh file on the 3rd cd, It starts to run but some warnings show up (even though the installer program starts up). I tried installing it despite the warnings but the install button on the program is greyed out and cant be used.. Thanks in advaced.

This is what i get:

Copying to a temporary location...
Verifying archive integrity... All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2107.........................
.............................................

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro
mismatch)

Gtk-WARNING **: GModule initialization check failed: Gtk+ version too old (micro mismatch)

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 490 (gtk_entry_get_text): assertion `entr y != NULL' failed.

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 490 (gtk_entry_get_text): assertion `entr y != NULL' failed.

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 490 (gtk_entry_get_text): assertion `entr y != NULL' failed.

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkEntry'

Gtk-CRITICAL **: file gtkentry.c: line 490 (gtk_entry_get_text): assertion `entr y != NULL' failed.

randomblast 12-19-2003 05:26 PM

do you know what version of GTK the installer uses?
you could do rpm -qa | grep gtk
that would show you what gtk packages you have installed
you need gtk 1.x and gtk 2.x for compatibility with all gtk programs, they will both reside on a system quite happily.
if rpm shows that 1.x is installed, install 2.x, and vice versa
if rpm shows that they're both installed, then that's very interesting...

although, the window is initializing, which is also very interesting, because it shows that it's quite happy with your gtk, it's possible that it's a minor revision problem, you should go to http://www.gtk.org/download/ and download gtk 1.2 and 2.2.
if you don't want to compile from source then i'm sure googling will find you some binaries for mandrake 9.2

thelenko 12-19-2003 08:37 PM

hehe, know I got another problem... I got the installation to start and it tells me to put in the playdisk, ive tried all 3 cds in both my cd rom drives but it still tells me to put it in..

randomblast 12-20-2003 08:26 AM

isn't the playdisc disc 1?
anyway, it's probably looking at /dev/cdrom or /mnt/cdrom
if you haven't already, make a symlink to /dev/hd<whatever> called /dev/cdrom
and give /dev/hd<whatever> global read-write permissions

and you could try running the installer from your hard drive if you're not doing that already


All times are GMT -5. The time now is 04:58 PM.