LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   Unreal 2003 (yes -- 2003) install headaches (https://www.linuxquestions.org/questions/linux-games-33/unreal-2003-yes-2003-install-headaches-168160/)

archlyn 04-09-2004 11:03 AM

Unreal 2003 (yes -- 2003) install headaches
 
Okay, I've been trying to install UT 2003 on my linux box for a couple hours now and have had no luck. I'm using Slackware-current and everytime I try to install it fails at some random point with this error

Code:

failed to uncompress file.
./setup.sh: line 214:  1367 Aborted                "$setup" "$@"
./setup.sh: line 214:  3220 Segmentation fault      "$setup" "$@"
The setup program seems to have failed on x86/glibc-2.1

These CDs work fine with windows.

I installed the first time and it failed on some file on disk 2

The next attempt got to somewhere on disk 3 and failed

This last attempt bombed on disk 1

I've been able to track down that this is apparrently a known issue but I can't find a solution for it.

System specs
-----------------
AMD Athlon XP 2400+
512mb RAM
GeForce 4 TI 4200 w/ nvidia 53.36 linux drivers installed
SB Live 5.1
kernel version 2.6.5

all slack packages up to date

Help! :(

Wayne_Zombie 05-14-2004 07:47 PM

man, i'm having the same problem with my install... here is my error messages:

=================================================
execv: Permission denied
Command: /mnt/hdb/Games/ut2003/tmp_script_v3IKUY
failed to uncompress file.
./setup.sh: line 214: 7067 Aborted "$setup" "$@"
.setup7051: dynamic-link.h:57: elf_get_dynamic_info: Assertion `! "bad dynamic tag"' failed.
./setup.sh: line 214: 7489 Aborted "$setup" "$@"
The setup program seems to have failed on x86/glibc-2.1

Fatal error, no tech support email configured in this setup
The program returned an error code (1)
==========================================================


i get this when it seems to be at or near the end of the 1st cd.... i'm running the script from my HD and i have no idea what is going on here.

Wayne_Zombie 05-18-2004 10:01 AM

ok, i found my problem. i was trying to install the game on my 2nd hd.... whenever i do this, i get permission denied when i try and run anything. anyone know how to fix this? i aparently have permissions to write to the drive, i just can't use it correctly. do i have to mount it in a special way? or does it have to be in linux ex3 format? right now i'm using it in fat so i can still use it in windows. what do i have to do?

Protex 05-18-2004 11:49 AM

archlyn:

I've installed UT2k3 on slack 9.1 with out a problem. This is how i did it:

1) Copy the setup.sh file off of disk 3 to you hd
2) Insert disk 1
3) su
4)run the setup.sh

Now this is from memory, but i'm pretty sure that the setup program will mount the cd for you when you run setup.sh and also unmount when you need to change cds.

Try it this way and let me know.


All times are GMT -5. The time now is 12:36 PM.