LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 08-27-2004, 10:50 AM   #1
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Rep: Reputation: 31
Trouble running Phobia III


Hey-
i am trying to run Phobia 3 on Suse 9.1 Pro. When i try to run it, it complains about libsdl or something (can give specific message later this evening). This lib is already installed, according to Yast.

any help anyone can provide on running this game would be great! looks like an awesome title

thanks,
-myk
 
Old 08-28-2004, 07:39 AM   #2
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
here's the error:
Code:
myk@linux:~/Applications/phobia3> ./phobia3 --window
./phobia3: error while loading shared libraries: libvorbisfile.so.0: cannot open shared object file: No such file or directory
myk@linux:~/Applications/phobia3>
i have libvorbis and libvorbis-devel installed, according to yast. I can play and encode ogg files, so ii assume it is installed.

and here's the link to the game in question:
http://www.lynxlabs.com/phobiaIII/download.html

thanks,
-myk
 
Old 08-30-2004, 01:07 PM   #3
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
anybody?
 
Old 08-30-2004, 01:59 PM   #4
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 31
The libvorbis package should provide libvorbisfile.so, it does when built from source. Perhaps you're missing a symlink, for example:

Code:
ls -al /usr/lib/libvorbisfile*
-rw-r--r--    1 root     root        19878 Oct 18  2003 /usr/lib/libvorbisfile.a
-rwxr-xr-x    1 root     root          777 Oct 18  2003 /usr/lib/libvorbisfile.la
lrwxrwxrwx    1 root     root           22 Nov 10  2003 /usr/lib/libvorbisfile.so -> libvorbisfile.so.3.0.0
lrwxrwxrwx    1 root     root           22 Nov 10  2003 /usr/lib/libvorbisfile.so.3 -> libvorbisfile.so.3.0.0
-rwxr-xr-x    1 root     root        27019 Oct 18  2003 /usr/lib/libvorbisfile.so.3.0.0
as you can see, on this system, libvorbisfile.so is a symlink to libvorbisfile.so.3.0.0

HTH

Mad.
 
Old 08-30-2004, 02:54 PM   #5
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
i'll check it and post back when i get home.

Thanks for the tip
 
Old 08-30-2004, 05:37 PM   #6
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
got the symbolic link fixed. But the game causes a segmentation fault. Soon as i begin to play it crashes with no specific error message. Any ideas on that?

thanks,
-myk
 
Old 08-30-2004, 06:27 PM   #7
QzarBaron
Member
 
Registered: Oct 2003
Distribution: Ubuntu 4.10
Posts: 76

Rep: Reputation: 15
EDIT: Never mind I am an idiot sorry.
 
Old 08-30-2004, 08:35 PM   #8
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Original Poster
Rep: Reputation: 31
got it fixed.. I needed to install one of the source packages included for smpeg.

works great now.

Thanks,
-myk
 
Old 04-16-2005, 11:54 PM   #9
cyborg_jim
LQ Newbie
 
Registered: Apr 2005
Posts: 1

Rep: Reputation: 0
Apologies for resurrecting the dead but I've also been having problems with Phobia III and managed to resolve the libvorbis issue with a symbolic link but I have been unsucessful in either finding out what it is in the SMPEG library that it is that resolves the segmentation fault or in compiling the library (although I already have the relevant packages installed).

Any help is appreciated.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Having trouble running X KerFork Linux - Newbie 2 05-16-2005 06:57 PM
error while running GTA III in Wine vegetassj2 Linux - Games 8 02-10-2005 05:31 AM
Trouble detecting 3com etherlink III tymanrocks Linux - Hardware 4 04-18-2004 11:57 AM
Trouble running xine gummimann Linux - Software 2 03-21-2004 09:44 AM
Trouble with 3Com Etherlink III card josefsvejk Linux - Networking 4 01-10-2002 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 06:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration