-   Linux - Games (
-   -   Supertuxkart: OpenGL problem (

NanakiXIII 05-28-2008 03:36 PM

Supertuxkart: OpenGL problem
I am trying to get the game Supertuxkart to work on Mandriva 2008.1. First of all, when I install it through the software manager, I cannot get it to work one way or the other. It creates an entry in the Menu that does nothing. I checked what it does, and it has "supertuxkart --log=file" specified as its command. I opened up a console window and tried executing "supertuxkart", but it does not recognize that as a command.

Next I just downloaded that game. It comes with a file (which I did not get through the software manager) that should start the game. However, when I try to run it, I get an error.


GLUT: Fatal Error in supertuxkart: OpenGL GLX extension not supported by display: :1.0
I think I have installed all the dependencies for Supertuxkart (OpenGL, PLIB, etc.). Does anyone know what the problem might be?

oskar 05-28-2008 04:01 PM

Have you installed the right driver for you video card?
run in terminal:
glxinfo | grep direct
Does it say yes or no?
Are you trying to run it as root?

NanakiXIII 05-28-2008 04:54 PM

When I execute the command you mentioned I get this:


[marco@localhost ~]$ glxinfo | grep direct
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".

I have installed drivers for my video card. It does not matter whether I run the file as root or not, I get the same output.

oskar 05-29-2008 02:33 AM

Hm, could you post your xorg.conf.

NanakiXIII 05-29-2008 08:58 AM

Sure. These are the contents of /etc/X11/xorg.conf. What do they tell you?


# File generated by XFdrake (rev 234840)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    #DontZap # disable <Ctrl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "glx" # 3D layer
    Load "dri" # direct rendering

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us(alt-intl)"
    Option "XkbOptions" "compose:rwin"

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"

Section "InputDevice"
    Identifier "SynapticsMouse1"
    Driver "synaptics"
    Option "SHMConfig" "on"

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName ""
    HorizSync 31.5-56
    VertRefresh 60-69

Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc"
    BoardName "ATI Radeon X1300 and later"
    Driver "fglrx"
    Option "DPMS"

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    Subsection "Display"
        Depth 8
        Modes "1280x800"
    Subsection "Display"
        Depth 15
        Modes "1280x800"
    Subsection "Display"
        Depth 16
        Modes "1280x800"
    Subsection "Display"
        Depth 24
        Modes "1280x800"

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "SynapticsMouse1" "SendCoreEvents"
    Screen "screen1"

oskar 05-30-2008 05:02 AM

Not too much unfortunately. The glx entry is there... I know there's a module that conflicts with the glx module... I forgot the name, but I guess I'd recognize it, so it's probably not there.
fglrx is the right driver to get 3d support for ATI...
The only thing that you might have a problm with is with compiz. I remember you had to add an allow-something-something line in some cases (I'm so sorry, I don't remember stuff like that)

So the only idea I have left is that you make sure you don't have compiz running and try it again:

metacity --replace&

That should kick compiz out and put metacity in place.

NanakiXIII 05-30-2008 11:41 AM

Apparently I did something to the ATI drivers while trying to install the rest of the dependencies. I just reinstalled the drivers and now everything seems to work.

I did have problems with Compiz, it wouldn't work, so I am not using it. However, perhaps Compiz will work now as well. I'll have a look some time.

Thanks for your help.

All times are GMT -5. The time now is 05:50 AM.