LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 10-23-2005, 09:49 AM   #1
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Rep: Reputation: 0
Quake 3 runs TOO fast


Hi, I am runnin slackware 10.2 Kernel 2.6.13.4 (append no_timer_check) with ati radeon x700, turion 1.6 ghz and X.org release number 60.802.00. The gflrx drivers are installed correctly. The problem is that the game runs extremely fast , as in fast forward. Below is my xorg.conf.

Section "Module"

# This loads the DBE extension module.

## Load "dbe" # Double buffer extension

SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"

# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"
EndSection

# **********************************************************************
# Files section. This allows default font and rgb paths to be set
# **********************************************************************

Section "Files"

RgbPath "/usr/X11R6/lib/X11/rgb"

# The module search path. The default path is shown here.

# ModulePath "/usr/X11R6/lib/modules"

FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/TTF"
FontPath "/usr/X11R6/lib/X11/fonts/ttfonts"
FontPath "/usr/X11R6/lib/X11/fonts/urw"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/local/share/fonts"
EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

Identifier "Keyboard1"
Driver "kbd"


Option "AutoRepeat" "500 30"

Option "XkbRules" "xorg"
Option "XkbModel" "ferrari4k"
Option "XkbLayout" "us"
Option "XkbOptions" "grp:alt_shift_toggle,lv3:switch,ctrl:ctrl_aa,grp_led:scroll,caps:shift"

EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************
Section "InputDevice"

Identifier "Mouse 0"
Driver "synaptics"

Option "Device" "/dev/input/mouse1"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
# Option "EmulateMidButtonTime" "75"
Option "VertScrollDelta" "100"
# Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.09"
Option "MaxSpeed" "0.18"
Option "AccelFactor" "0.0015"
# Option "EdgeMotionMinSpeed" "200"
# Option "EdgeMotionMaxSpeed" "200"
Option "UpDownScrolling" "1"
Option "CircularScrolling" "1"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"

# Option "SHMConfig" "on"

Option "ZAxisMapping" "4 5 6 7"

EndSection

Section "InputDevice"

# Identifier and driver

Identifier "Mouse 1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"


# **********************************************************************
# Other input device sections
# this is optional and is required only if you
# are using extended input devices. This is for example only. Refer
# to the xorg.conf man page for a description of the options.
# **********************************************************************
#
Section "InputDevice"
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
EndSection

# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

Identifier "My Monitor"


HorizSync 30-67

VertRefresh 30-60

EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

# Device configured by xorgconfig:

Section "Device"
Identifier "x700"
Driver "fglrx"
BusID "PCI:1:0:0"
Option "no_accel" "no"
Option "no_dri" "no"
Option "mtrr" "off"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "UseInternalAGPGART" "yes"
# VideoRam 131072
# Insert Clocks lines here if appropriate
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************
Section "Screen"
Identifier "Screen 1"
Device "x700"
Monitor "My Monitor"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x800"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x800" "1024x768" "800x600"
ViewPort 0 0
EndSubsection
EndSection

# **********************************************************************
# ServerLayout sections.
# **********************************************************************
Section "ServerLayout"

# The Identifier line must be present
Identifier "Simple Layout"


Screen "Screen 1"

InputDevice "Mouse 1" "CorePointer"
InputDevice "Mouse 0" "AlwaysCore"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "DRI"
Mode 0666
EndSection


Thanx in advance
 
Old 10-25-2005, 01:42 PM   #2
beeblequix
Member
 
Registered: Oct 2005
Location: Tierra Firma, Earth
Distribution: Debian of course...
Posts: 198

Rep: Reputation: 30
you probably installed the game when not plugged into the wall, consequently it set everything up according to the power-saving speeds.

This isn't a unique linux type problem -- I've heard about this on Windows platform first.

I guess to fix it you could either 1)dedicate only running it while unplugged 2)uninstall, plug in to the wall and reinstall there. Note: you may do #2 and notice the game running way too slow when not A/C connected....

Hope this helps.

 
Old 10-25-2005, 05:11 PM   #3
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
Well, that would make sense if I couldn't change the cpu frequency afterwards. If you were right , the game would run fine if I set the clock speed back to the one I had set when I installed it, but that doesn't happen.
Thnx for the reply anyway.
 
Old 10-28-2005, 06:55 AM   #4
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
Same thing happends for quake 4 ! (probalby doom 3 too).
Has anyone got a clue?
 
Old 10-29-2005, 06:16 PM   #5
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
bump
 
Old 11-03-2005, 12:53 PM   #6
mgmax
Member
 
Registered: Jul 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 16
Did you read the answers? The power-management switches down the CPU speed when your laptop runs on battery and switches it up when your laptop gets plugged into the power outlet.

Q3 or any other games tests the speed at the first run and if the CPU then gets faster, it runs too fast.


You could try to edit the maxfps or fpsrange (dont know the exact name) value in the config.

Max
 
Old 11-03-2005, 01:54 PM   #7
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
Yes I did read the answers but it seems you didn't read my replies :-)
As I said, It is not a matter of fps. Apart that, I keep the frequency at fixed value, tried both 800 mhz and 1.6 ghz.
 
Old 11-04-2005, 02:23 PM   #8
beeblequix
Member
 
Registered: Oct 2005
Location: Tierra Firma, Earth
Distribution: Debian of course...
Posts: 198

Rep: Reputation: 30
just for kicks & giggles can you uninstall then reinstall while plugged in to AC? I still think that's where to begin.
 
Old 11-04-2005, 02:29 PM   #9
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
Already done that, no luck
 
Old 11-07-2005, 11:59 AM   #10
lpd
Member
 
Registered: Nov 2004
Distribution: Debian Unstable
Posts: 77

Rep: Reputation: 15
You can try stressing out the CPU (ie making it go at full speed) as you start up the game. There was a few notes about similar problems in the Doom3/Quake4 FAQ/Readme. The game adjusts timers at game startup when your CPU probably is running at reduced speed, then when CPU speeds up due to the increased load the game also speeds up.
 
Old 11-08-2005, 11:30 AM   #11
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
I'll give it a shot. Thnx
 
Old 11-14-2005, 05:43 PM   #12
beeblequix
Member
 
Registered: Oct 2005
Location: Tierra Firma, Earth
Distribution: Debian of course...
Posts: 198

Rep: Reputation: 30
*bump*

I'm still interested if you got a solution yet.

 
Old 11-15-2005, 05:45 AM   #13
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
Sorry I didn't try it yet. I will soon.
 
Old 11-16-2005, 03:45 PM   #14
wick0r
LQ Newbie
 
Registered: Oct 2005
Location: Greece
Posts: 10

Original Poster
Rep: Reputation: 0
No luck again...
 
Old 02-20-2006, 04:14 PM   #15
Avenging_Angel
LQ Newbie
 
Registered: Jan 2003
Posts: 16

Rep: Reputation: 0
Try locking the framerate in Q3. Just press ~ to bring down the console and type /seta com_maxfps 60 or something to that effect ^_^ if that isnt the command try just typing com_ and press the TAB key to see what the com_ commands are hope this helped n_n
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Shogo MAD runs kinda too fast Dr. Device Linux - Games 1 10-12-2005 08:04 PM
AMD 64 frequency scaling issue - everything runs too fast! gracecourt Linux - Software 8 08-21-2005 06:49 PM
Games runs slow as normal user, but fast as root user mcore Linux - Software 2 06-07-2004 11:11 PM
ntp hell: System clock runs twice as fast as it should do jimieee Linux - Software 0 01-23-2004 05:17 AM
I have got a celeron box, 1.1Ghz. It runs very fast with windows XP ..But its only cr eccentrinbe Linux - Hardware 2 11-19-2003 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration