-   Linux - Games (
-   -   Quake 2 sound stuttering - can I cure this? (

rockhard1972 01-05-2004 06:52 PM

Quake 2 sound stuttering - can I cure this?

This is my first venture into linux with Slackware 9.1.
I've been using Kernel 2.4.23 and have recently upgraded to 2.6.0.
I left ALSA (version 0.98?)as it was installed and setup with previous Kernel, just copying contents of module.conf to the new config.modules.
All Alsa options in Kernel including OSS emulation are compiled in or modular where appropriate.
This has worked great and my sound has continued on with the new Kernel without a hickup till now :(
I really want to get back into playin Quake2 again after a 2 year break and have managed to get it up and working using the Loki ID software source installer from Iccarus + q2hack :)
Everything is perfect but the sound! :(
Whenever i play the game the sound comes on for a second, then mute's for a couple of seconds, then plays again for a second and so on.........
Strange thing is Call of Duty (WineX), Quake 3, Homeworld2 sound great. :/
I'm now really stuck and don't want to trash my Slack install so would be really grateful for some advice/help.
If any of my config scripts would be of help please let me know and i'll post them here.



LavaDevil94 01-05-2004 08:23 PM

hmm... are you using some kind of sound server like aRts or esd? if so, disable them and see if that helps.

rockhard1972 01-05-2004 09:22 PM

I had never thought of Arts or Esd.
I've heard of Arts before - Is that the sound server that KDE uses?
I use Gnome as my Desktop having only ever booted into KDE once for a nosey.
Even in Gnome could Arts still be working after a fresh boot?
Esd i've never heard of so i'll have to have a looksee with google and have a sniff over my system.
Never having installed these myself could they have been installed at OS install time without me realising?
I'm currently in XP right now :o so do forgive me if I dont reply straight away.
Will post my progress in the afternoon tomorrow when i get the chance.


LavaDevil94 01-05-2004 09:39 PM

well, do 2 commands and see if it helps:
killall -9 -v esd
killall -9 -v arts

rockhard1972 01-06-2004 05:22 AM


root@# killall -9 -v esd
Killed esd(949) with signal 9
root@# killall -9 -v arts
arts: no process killed

Is esd the sound server for Gnome system events?

Just fired up Quake2 and still the pauses in the sound :(
Is there anything else I can try?

jspenguin 01-06-2004 12:44 PM

Are you using the quake2 binary or the sdlquake2 binary? Try switching to the other one. I've had good luck with sdlquake2.

LavaDevil94 01-06-2004 03:14 PM

AFAIK, esd is the gnome sound server (Enlightened Sound Daemon).

rockhard1972 01-06-2004 06:20 PM

jspenguin - I've tried both the ID software 3.21 engine using the Loki installer and also the one available at (version r0.15?) and they both give the same problem with sound.
I'll have a look at the CVS snapshot at icculus and give that a go when ive posted this :)

LavaDevil94 - Thanks for the info.

rockhard1972 01-06-2004 06:43 PM

No joy - Just tried the latest release from but still the same :(
Must be something in my system config letting me down i guess.
Next thing to try is updating Alsa from 0.98 to 1.rcx.
I will have to do some reading up first before i try this to help prevent me borking my rig :D
Will pop the outcome up here tomorrow when i get time to try.



sHoRTie 04-13-2004 05:31 PM

Hi I have the same problem, using Suse 9.0 with a 2.4.* kernel and already tried the different alsa versions. atm 1.0.4. but still have the choppy sound.

Im running nocheat because its required for the actionquake2 leagues.

What i have also tried: sndbits 8 and 16 sdnchannels 1 / 2. sndspeed 8000 / 11025 / 22051 / 44100 none of these combinations did work. Soundcard is a Soundblaster Pci128. and quake3 enemyterritory and diablo2 under winex are all running fine (programs like teamspeak or xmms also)

would nice to hear if someone could help us 2 :)

Btw. no snd daemon is running

bobby Digital 04-13-2004 07:09 PM

echo "quake2 0 0 direct" > /proc/asound/card0/pcm0p/oss
where 'quake2' is the name of your quake executable.

Btw, I use nocheat, myself.

sHoRTie 04-15-2004 12:37 PM

this did not change anything :(

im trying to get another soundcard. think its the only thing that solves that :((

norfenstein 09-27-2004 04:26 PM

Has anyone solved this yet? I'm having the exact same problem.

orgee 09-29-2004 12:14 PM

I got the same problem, but it doesnt happen only in Quake3, but also in UT2k4.. Sound hiccups and it lags my overall spitting of frames in the screen cuz of it.

shanshand@gmail 10-21-2004 08:20 PM

Anyone solved this problem
I just came across the same problem with quakeforge on redhat 9.0. kernel 2-4-31
Thanks a lot

All times are GMT -5. The time now is 08:46 PM.