LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 03-30-2004, 01:22 PM   #1
meisterlampe
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
Unhappy problem with glx q3a on debian (nvidia)


well,
once i installed quake3 on my computer and everything worked fine..
now with kernel 2.6 i had to use the automatic installation proggie from nvidia, since the nvidia-kernel and nvidia-glx dont work with kernel 2.6 (? - i'm unsure about that)

after i have installed kernel 2.6 and the new nvidia drivers i tried quake3, didn't work
had some problems with libmesa first, i fixed these problems and now i have a new problem..

here is the output:

----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.1
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
..........
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
...loading libGL.so.1: Initializing OpenGL display
...setting mode 3: 640 48
Using XFree86-VidModeExtension Version 2.1
XFree86-VidModeExtension Activated at 640x480
Xlib: extension "GLX" missing on display ":0.0".
..........
Xlib: extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem


now glxinfo , glxgears doesn't work ...

in my XF86-Config4 glx,GLcore is activated:
Load "glx"
Load "GLcore"


does anybody know how i can make q3 run now?
how can i install glx ...
 
Old 03-31-2004, 09:18 AM   #2
meisterlampe
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Original Poster
Rep: Reputation: 0
okay, i fixed the error..
well it was my fault

i didn't update my XF86-Config4.
he tried to use glx from my old 2.4 kernel.. it didnt work..

just read /usr/share/doc/NVIDIA_GLX-1.0/README

maybe this'll help someone *gg*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia legacy driver and nvidia-glx questions darkleaf Linux - Software 6 06-27-2005 02:42 PM
nvidia glx acceleration won't work in kde on debian sillyd Linux - Hardware 4 01-29-2005 08:18 AM
GLX/Xfree86/DRI/nvidia geforce 4 mx 420 problem asalford Linux - Hardware 3 04-01-2004 02:28 PM
GLX NVidia Problem countcobolt Linux - Software 5 12-05-2003 11:34 AM
Nvidia/GLX Problem after upgrade darcon3k Linux - Software 6 08-20-2003 11:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration