-   Linux - Games (
-   -   must.. have.. starcraft (which wine to use?) (

End11 12-10-2003 10:41 PM

must.. have.. starcraft (which wine to use?)
so i want starcraft to run under wine/winex in mandrake 9.2. ive been trying to make this happen, i googled, looked at numerous faqs/howtos. I installed it with the newest freely available winex (it installed, ran poorly, woudn't update, crashed, and wouldnt run anymore) with the newest wine (it installed, ran quite well, crashed, gave some weird error message, then brought up a blank screen that i had to kill x to get out of every time i tried to run it, and hasn't worked since) and with an older version of wine (didnt work at all) because i read something on this site that said that might help.

anyway all i really want to know is those of you who have starcraft working, what version of wine did you use? also, how did you set up your .wine directory, and did you run it from a fake or real windows drive? i just need somewhere to focus on that i know CAN work.

any help is much appreciated, starcraft is the second to last program i still need windows for.

End11 12-10-2003 11:16 PM

ok for the specifics of one problem:
im trying again with the newest wine (which i had working for a few precious minutes earlier today) and ive gotten to a point where my x is in 8 bits, and im trying to run starcraft with the desktop setting on in wine. this is the output i get:

[chris@localhost chris]$ wine fake_win/Starcraft/starcraft.exe
Loading required GL library /usr/X11R6/lib/
fixme:console:SetConsoleCtrlHandler (0x4ca13b,1) - no error checking or testing yet
wine: Unhandled exception (thread 0009), starting debugger...
WineDbg starting on pid 8
No debug information in ELF 'wine' ((nil))
No debug information in 32bit DLL 'Y:\fake_win\Starcraft\starcraft.exe' (0x400000)
No debug information in 32bit DLL 'NTDLL.DLL' (0x40200000)
No debug information in 32bit DLL 'KERNEL32.DLL' (0x40490000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x40700000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\CRTDLL.DLL' (0x406e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x40740000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x40aa0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40920000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\RPCRT4.DLL' (0x40c50000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x408a0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x40ca0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x40cf0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x40810000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\WINSPOOL.DRV' (0x40da0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMDLG32.DLL' (0x40780000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\LZ32.DLL' (0x40de0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\VERSION.DLL' (0x40dd0000)
No debug information in 32bit DLL 'Y:\FAKE_WIN\STARCRAFT\STORM.DLL' (0x15000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x40eb0000)
No debug information in 32bit DLL 'Y:\FAKE_WIN\STARCRAFT\LOCAL.DLL' (0x2000000)
Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x40ed68cb).
In 32-bit mode.
0x40ed68cb (X11DRV.DLL.SwapBuffers+0x1b5b in X11DRV.DLL): cmpb %dl,0x0(%ecx)

i can enter stuff at the WIne-dbg> prompt but i have no idea what to.
what really kills me is i had this working for a good 5 minutes. :"(

MNKyDeth 12-11-2003 12:46 AM

Hmm, I don't have these probs you speak of with Starcraft and wineX. Let me give you my run down.

I use Arch linux, 2.6-test11 kernel, 4260 nvidia beta drivers, GFFX5800, SBAudigy2zs.
I used the most recent version of wineX, currently 3.2 with Point2play. I install Starcraft then Broodwar like normal then I DL the patch and install the patch like I would a game, instead of trying to DL it from <- that never seems to work DL'ing from

I have the game installed on an Ext3 partition, (I don't have any Fat32 drives or parts).
I have been able to play the game over my network and on My xfree86 resolution is 1280x1024x24. <- Remember, games will always run at the color depth the desktop is set at. This is just the way xfree is, it may and most likely will change in the future as it becomes more advanced.

Also, if you have a subscription ask on the transgaming site also. If you don't ask you'll never know, exposure is key. :) Also, check there site if you havn't already to see if others are having the same or similar prob.

In Point2play, I have the stock config for the game. I have noticed some games really like the win2k setting much more than win98 IMO.

Well, gl, if you find anything or some fix please let us know. I am sure others will help also.

End11 12-11-2003 10:33 AM

thank you very much for answering me so quickly. i will certainly try winex as soon as i get home, in the meantime you reminded me that i should probably post some system stats
im running:

mandrake 9.2 with the 2.4.22-10mdk kernel, i have a radeon 9000 pro which i havent installed ati's drivers for because mandrake seems to have taken care of it, crappy onboard ac97 soundcard, 512 ddr ram, and a p4 1.6 ghz.
my xfree is running 1024x768x16, and i have tried installing startcraft on a reiserfs and a fat32 partition, although i also have some ext3 lying around if you think that would help.

anyay thanks again for your help and ill be back later tonight to try winex and post my errors from that :D

mymojo 12-11-2003 01:36 PM

I believe wineX is requires a transfer of funds, which may or not be an issue - have you been naughty or nice?

End11 12-11-2003 04:50 PM

im pretty sure theres free versions out there which just lack the proprietary copy protection emulating bs that the real one needs to license (correct me if im wrong, i wouldnt want te do anything illegal ;) but should be fine to run starcraft. as for santa claus, the man's supposed to be bringing me a new soundcard, so i think asking for a transgaming membership might be pushing it.

LavaDevil94 12-11-2003 06:01 PM

i run starcraft fine on:
radeon 9000
mandrake 9.1 w/ 2.4.21-0.13mdk (its been giving me problems, actually!)
512 geil ddr ram
athlon xp 1.666ghz
(phrase that rhymes with 'lease of bit' here) c-media 8738 onboard sndcard
winex 3.2 (no point2play, i actually find it tedious)

btw End11, even if mandrake seems to handle it fine, you really should install the ati drivers. the drivers from the vender are always better then the opensource ones. i only have one problem with starcraft: all winex games default to 640x480, which is off my moniter screen. and starcraft doesnt have a res switch option.

End11 12-11-2003 09:30 PM

ok so i got a (slightly questionable) version of winex. starcraft and the expansion installed fine, and i could run/play them in single player fine although it was very choppy. i think that might have been something to do with my cd drive, it seemed to respond very slowly. anyway i tried to install the latest batch, but that did nothing. now starcraft will load, but it goes even slower (takes about five minutes to start, again it sounds like the cd drive is taking forever to respond). i tried to get the patch ingame, and it seemed to download it successfully, but when it went to restart the app to apply the patch it just gave me a black screen and did nothing.

so now starcraft still runs (kindof? somtimes?) after about 5-10 minutes of just sitting there but still can't play on bnet. have you guys successfully got the latest bnet patches? if so did you do it differently from me?

well i think ill go back and try in nice, regular, free wine. i had about the same results there before, only before the patch it ran smoother.

End11 12-11-2003 09:48 PM

unf. so it installed, and ran more smoothly than it did on winex, but even thinking about patching it seems to make it incapable of running at all. i get the same black screen that can only be escaped by killing x.

i'm not going to give up, but i cant think of anything else to try right now.

i installed wine with wine-20031118-mdk.i586.rpm if that helps.

LavaDevil94 12-12-2003 03:54 PM

maybe the cd problem had something to do with your cd drive not having dma enabled...

End11 12-12-2003 06:10 PM

how do i fix that? ive tried hdparm but im not sure im doing it right..

thumper 12-13-2003 01:18 AM

I had epic battles with Mandrake 9.0 and video configuration as a raw Newbie. (I think I'm up to Newbie-ish by now). The details aren't relevant here but - my 2 cents worth would be to get the video drivers updated and then keep experimenting. Most games these days (and for the last 5 years or so) are heavily dependent on video configuration for good performance. Get all your ducks in a row there and you can (hopefully) reduce one of the variables.............. good luck and keep at it.

LavaDevil94 12-13-2003 10:51 AM

ya, you should use the ati drivers. they have s3tc texture support, if you ever wanna play ut2003, then you have to have that, otherwise itll bomb out. still, the vendor drivers always give better performance, and they have higher compatibility with everything.

End11 12-13-2003 02:45 PM

ok i will try installing my vid card drivers. unfortunately yesterday i had a relapse, and i couldn't go any longer without playing counterstrike. so i installed windows. unfortunately, windows is completely incapable of running from anything exept the master hd, so i had to switch them around. now im not sure how to boot into mandrake without reinstalling it. i know this is sortof off topic from the original post but is it possible to get back into mandrake now that i switched the two hds?

mandrake is on my 120 that has lilo in the mbr that was master, and is now slave. windows is on my 40 that was slave and is now master.

curse my counterstrike/starcraft addiction!

LavaDevil94 12-13-2003 08:16 PM

why dont you switch the slave/master channels/hd's manually?
ps: i think you might be able to get counterstrike to work under winex...

All times are GMT -5. The time now is 06:09 AM.