LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 04-17-2006, 06:28 PM   #1
thepagan
LQ Newbie
 
Registered: Apr 2006
Posts: 1

Rep: Reputation: 0
Minor issues running a cod2 server in xandros 3...


Hello everyone,

T'm a newb to linux, but learning. i posted this on xandros forums, but no help yet. If anyone has any experience running game servers on linux their input is appreciated..


rst of all, hello to all. i've been working with windows for years, and the linux bug has finally bitten me. It's easy to see why it's very popular for servers and desktops.
So heres my problem. i created a folder on my desktop and loaded the cod2 files in it. I just got the latest binaries and installed them, as the game has just been patched.
My problem is twofold, one, making changes to the executable to run my config, and second, to get punkbuster running (an anticheat tool, just in case
someone dosen't know)
Being a Windoze guy, i right clicked, went to the properties of the exe file,
and tried to add some commands (or arguments, whatever you prefer to call them) to that exe.
The game server starts correctly, so i know i have the files in the right place, but i have to manually start my config file from the console. I'm assuming that these changes have to be done fron the Xandros console, but i honestly don't know enough about linux at this point to do it.
Also of note I run as root, since i'm the only one who uses this particular PC, and my login has full administrative priveliges.
As far as punkbuster, i installed and updated it, but when i run my config, i get an error message. The message says "sv_punkbuster is write protected" Please note this error message comes from the cod 2 console when i start my config.
I'm assuming that this is a permission problem, but i have all permissions to this file (and all the folders, etc.)
I hate to bug everyone with newb stuff, but I must be doing something wrong!
Any help would be greatly appreciated, and any links to detailed info
on running linux servers would help.

Thank you
-Storm- aka thepagan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Latitude D800 - Three Issues [one severe, two minor] spaceballs Slackware 10 01-31-2006 02:22 PM
Minor FireFox issues with Gentoo vharishankar Linux - Software 9 04-26-2005 11:35 PM
A few minor KDE issues DaBlade Linux - General 15 12-21-2004 07:19 AM
Minor Mozilla issues...... CaptainInsane Linux - Software 2 12-08-2003 07:58 PM
gnome2 - several minor issues timorei Linux - Software 0 03-11-2003 06:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration