LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   mame running on wineX (https://www.linuxquestions.org/questions/linux-games-33/mame-running-on-winex-192322/)

madskillz 06-11-2004 09:48 AM

mame running on wineX
 
i heard there was a free version of wineX around, and i just wanted to know with MAME (the windows MAME) will run on it

b0uncer 06-11-2004 11:23 AM

why don't you use Xmame instead, the one for linux? I mean, what's the point running an emulator with an emulator? :)

and as far as I know, there is _no_ free version of wineX around. that'd be quite the same like saying that "hey, there's a free version of Windows around"...

unless I've missed something big.

madskillz 06-11-2004 11:25 AM

i have so much trouble installing that thing...after i compiled xmame, and got the xmame.x11 file, my frontend, gxmame says that the xmame executable file is not there. What could be wrong?

proudclod 06-11-2004 11:26 AM

There is a free version of winex, in that you can download the source from them, and compile it yourself.

However, it's hard to do, oft not reliable, and you loose some functions.

Why not just subscribe, 15 bucks ain't bad considering they'll give you tech support.

b0uncer 06-11-2004 11:33 AM

proudclod: the reason why 15 bucks _is_ bad is that it's more than 0 :) I mean, if you are ready to pay for playing, why not buy windows? it works (yet) better with games than linux...altough this may change (unreal's newest has a linux-installer too), but as long as it is so, I don't see a reason to pay for something that is not sure at all.

this wouldn't be that bad if there was a guarantee that it works at least as well as real windows with every game, but as long as this isn't so, I don't want to pay. and linux is open source, so I like to keep it that way...and many of us get a copy of windows along with their pcs when they buy one, so they have a chance to make it dual-boot to play with it and not pay 15 bucks for not-that-good-and-not-reliable thing...

madskillz 06-11-2004 11:38 AM

could someone help with the xmame problem?

b0uncer 06-11-2004 11:45 AM

can you run the executable of xmame itself, without gxmame? also, can you specify where gxmame looks for the xmame's executable?

madskillz 06-11-2004 11:47 AM

no it doesnt run by itself. it is looking for the file in home/ahmad/xmame-0.80.1/

b0uncer 06-11-2004 11:49 AM

and when you run gxmame from a terminal, do you get any other error messages that might enlighten this problem...?

EDIT: how about the compilation of xmame - did you get any errors in it? and gxmame?

madskillz 06-11-2004 11:50 AM

nope not at all

b0uncer 06-11-2004 11:54 AM

hmm...have you tried to run xmame with another frontend, like Romeo, just to see if that helps?

madskillz 06-11-2004 11:55 AM

hmm, na i havent, i'll try it

b0uncer 06-11-2004 12:00 PM

one more thing - according to xmame's homepage, you should be able to run xmame itself without any frontend (from a console/terminal) with a command:

xmame [options] <gamename> [more options]

so...if that won't work, you'll have to recompile

EDIT: what files do you exactly get when compiling?

madskillz 06-11-2004 12:34 PM

well i try getting the rpm instead so i didnt have to compile. i downloaded the rpm and it said i had a unsatisfied xmame-base. so i downloaded that rpm. when i tried installing it, it said:

Some package requested cannot be installed:
xmame-base-0.82.1-1plf.i586 (due to unsatisfied xmame[>= 0.37b15.1-2mdk])
do you agree ?

exactly what file does it need?

azraelder 06-11-2004 10:47 PM

This is slightly off topic so I apologise for that, but does anyone know where I can download an old version of Xmame (around mame 32 release).
The Rom format changed around this time so some (most!) of my roms don't work.

On the mame site all the versions seem to be avaliable so I can run them under windows but it would be good to run them in Linux. Xmame does run well the roms that do work.

The Xmame site seems only to have the latest version. Can anyone help?

azraelder


All times are GMT -5. The time now is 06:09 AM.