-   Linux - Games (
-   -   Kobo Deluxe -- errors in make (

gymnart 04-30-2008 11:03 AM

Kobo Deluxe -- errors in make
I was trying to compile Kobo Deluxe 1.5.1 on my SuSE 10.0 box but I got these error messages from "make":


errors from make:
glSDL.c: In function ‘glSDL_SetVideoMode’:
glSDL.c:946: error: ‘SDL_GL_SWAP_CONTROL’ undeclared (first use in this function)
glSDL.c:946: error: (Each undeclared identifier is reported only once
glSDL.c:946: error: for each function it appears in.)
make[2]: *** [glSDL.o] Error 1
make[2]: Leaving directory `/home/<username>/rpms/KoboDeluxe-0.5.1/graphics'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/<username>/rpms/KoboDeluxe-0.5.1'
make: *** [all] Error 2

According to YaST, I have SDL, SDL devel 1.2.8 and the matching SDL Image, and SDL Image devel.

Here is part of the ./configure section:

from the config section:
checking for sdl-config... /usr/bin/sdl-config
checking for SDL - version >= 1.2.0... yes
checking for IMG_Load in -lSDL_image... yes
checking for OpenGL support... yes

checking SDL/SDL_opengl.h usability... yes
checking SDL/SDL_opengl.h presence... yes
checking for SDL/SDL_opengl.h... yes

How can I resolve this?

sleekslack 05-01-2008 09:14 PM

I'm not sure about this, but it's looks like errors in the source to me, not dependencies.

gymnart 05-02-2008 09:01 AM

I'll try contacting the developer then.

oskar 05-07-2008 09:00 PM

You could try the fedora rpm's.

gymnart 05-08-2008 12:29 PM

SuSE 10.0 can use Fedora's rpm's and it won't ruin the O.S.? :confused:

I got an answer from the developer and he told me that the error means, "You need at least SDL 1.2.10 or later for SDL_GL_SWAP_CONTROL to be
defined." and, "If you can't/don't want to upgrade SDL, you can comment out the lines that need this define."
Also, he told me that it would work on my system anyway, "All it does is allow the game to control the way OpenGL performs screen updates, on platforms and drivers that support this. It's not a critical feature in any way."

Thanks for your info. :D

sleekslack 05-09-2008 12:30 AM

That's my mistake then. I thought SUSE would have the latest SDL though :D

oskar 05-09-2008 04:09 AM


Originally Posted by gymnart (Post 3147162)
SuSE 10.0 can use Fedora's rpm's and it won't ruin the O.S.? :confused:

Why would it ruin the OS?
Worst thing that can happen is that it won't run... or you don't have all the dependencies...

gymnart 05-09-2008 11:51 AM

I don't know how it works with Ubuntu but with SuSE, the software has to be made for that particular version. I've been told that software packaged for 10.3 won't work well for 10.0, that dependencies would be broken (or something like that).

oskar 05-09-2008 06:15 PM

Broken dependencies is the name of the game on rpm based systems :P - but that's nothing to be afraid of. If the dependencies can't be resolved... well... it won't work, but it won't break your system.
It is of course better to install the rpm's that were made for your distribution, but if they are not available, I would look for other pre-built packages before starting to compile.

On deb based systems you can even install rpm's if you remodel them with alien... I don't know if alien works the other way around.

All times are GMT -5. The time now is 11:11 PM.