LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 01-12-2005, 06:30 PM   #1
dr_zayus69
Member
 
Registered: Sep 2004
Location: western massachusetts
Distribution: fedora core 3, Suse 10
Posts: 877

Rep: Reputation: 35
how to enable direct rendering.


i did glxinfo | grep direct and it shows that i do not have direct rendering enabled. What config file do i have to edit to enable it? Im using FC3

i am trying to enable it because Unreal Tournament GOTY edition runs very choppy. Would enabling it fix that? Do i need to download the nvidia driver? My card is Nvidia GeForce2 MX thanks in advanced.
 
Old 01-14-2005, 05:39 PM   #2
dr_zayus69
Member
 
Registered: Sep 2004
Location: western massachusetts
Distribution: fedora core 3, Suse 10
Posts: 877

Original Poster
Rep: Reputation: 35
I just downloaded and installed the nvidia driver. In the directions it said to make sure that dri does not load in the xorg conf file. Does that mean it automically enables direct rendering?
i tried doing glxinfo | grep direct to find out again and i get this message.
[jeff@x1-6-00-10-b5-f4-57-ac ~]$ glxinfo | grep direct
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display (null)

im trying to enable it to get UT working. It used to be really choppy. now it won't start at all. when i do ut i get this message:
[jeff@x1-6-00-10-b5-f4-57-ac ~]$ glxinfo | grep direct
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display (null)
[jeff@x1-6-00-10-b5-f4-57-ac ~]$ ut
Unreal engine initialized
Bound to SDLDrv.so
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

appError called:
Couldn't initialize SDL: No available video device

Executing UObject::StaticShutdownAfterError
Executing USDLClient::ShutdownAfterError
Signal: SIGIOT [iot trap]
Aborting.
Exiting.
Name subsystem shut down

can anyone help? thanks in advance.
 
Old 01-15-2005, 02:04 AM   #3
MNKyDeth
Member
 
Registered: Sep 2003
Location: USA
Distribution: Fedora Core 10 x86_64
Posts: 100

Rep: Reputation: 15
Once you have the nvidia drivers installed go into your /etc/X11/xorg.conf file. My file may differ slightly from yours as I don't run FC3 but the relevent sections should be there.

You need to have glx uncommented and dri commented like this.

# This loads the GLX module
Load "glx"
# This loads the DRI module
# Load "dri"

The # is a comment, meaning that line is not read or is skipped when the X server is started.
Also, if you have Load "GLcore" or something very similar make sure that is commented aswell.

Now, scroll down further and find this section, or something similar to it.

# Device configured by xorgconfig:

Section "Device"
Identifier "GFFX 5800nu"
Driver "nv"
#VideoRam 131072
# Insert Clocks lines here if appropriate
EndSection

In that section you need to make some changes so it looks like this.
# Device configured by xorgconfig:

Section "Device"
Identifier "GFFX 5800nu"
Driver "nvidia"
Option "NvAGP" "3"
#VideoRam 131072
# Insert Clocks lines here if appropriate
EndSection

Now, the Identifier line do not touch. You Linux OS should have filed that in or you put the name in while configging xorg. The main changes are the Driver "nv" to "nvidia". When you start your X server it should now load with the nvidia drivers instead of the dri drivers that don't have 3daccelleration.
The Option "NvAGP" "3" makes sure you have some sort of agp enabled for your vid card. This makes it so the vid card has access to the system memory incase it needs to read and write from it. In your bios you can set this size from 32 to 256 usually. Leave it at default of 64 and play your games. If you desire it you could try 128 to see if it helps any with performance. The "3" from that "NvAGP" line tells the X server to use the agp that the kernel has. If the kernel does not load an agp driver for your card then it will default to using the nvidia agp drivers. So basically the "3" is a catch all, it basically makes sure your agp interface has drivers loaded for you.

There may be some specific issues with FC3 and the nvidia drivers and such wich I didn't covor. All I did was give a straight out "what to change for the nvidia drivers" config for a standard install.
If you still have issues you can reply and i will see what I can do, or you can check here as they overall might be able to help better.
http://fedoraforum.org/forum/

Also, since i have seen some of your other posts, here is a list of games with guides for installing them incase you need it.
http://www.easylinuxguide.com/index....80ec243984fc4c

GL, HF
 
Old 01-15-2005, 03:37 AM   #4
dr_zayus69
Member
 
Registered: Sep 2004
Location: western massachusetts
Distribution: fedora core 3, Suse 10
Posts: 877

Original Poster
Rep: Reputation: 35
thanks for the help. I basically configured xorg that way but instead of commented load dri out i deleted, but commenting it seems the better choice cuz to enable it again i just need to uncomment it. Im not sure if i uncommented the glxinfo and i know that i did not know about that agp line so that was a big help. I'll make those edits later because right now im in FC2. The weird thing is that i can start UT fine from the menu but not from the commandline. So maybe those edits might help with that. I have gotten so used to linux and the command line that i rarely bother with the start menu so if i didn't stumble apon the UT menu icon i wouldn't have been able to play it. (So far it has ran pretty smoothly without problems)
 
Old 01-15-2005, 03:53 AM   #5
MNKyDeth
Member
 
Registered: Sep 2003
Location: USA
Distribution: Fedora Core 10 x86_64
Posts: 100

Rep: Reputation: 15
Well, if you installed the game to /usr/local/games/ut
All you would have to do in the terminal is go cd /usr/local/bin/ then ./ut
Or you could cd /usr/local/games/ut/ then ./ut
Tab completion is your friend as I don't have UT installed and can't remember if it was ut or UT or something lol.
 
Old 12-12-2005, 03:52 PM   #6
BobRobertson
LQ Newbie
 
Registered: Jul 2002
Location: Rocky Mount, North Carolina
Distribution: Debian
Posts: 12

Rep: Reputation: 0
Hey, this is good information. I'm trying to turn up SecondLife under Wine, and it's telling me that "direct rendering: no" as well as "16 bpp" instead of 24.

I've verified that everything in the above thread is set, I'm running Debian Sid so it's also Xorg, with one difference: I'm using the "nv" free-as-in-freedom module, not the "nVidia" binary module.

Because of this, I've left "Module dri" enabled in the xorg.conf. Should I still comment that out?

Bob-
 
Old 05-24-2008, 07:10 AM   #7
Zeusz3
LQ Newbie
 
Registered: May 2008
Distribution: Debian 4.0
Posts: 17

Rep: Reputation: 0
hello
this is what i get when i try to test if dri is enabled
$glxinfo | grep direct
bash: glxinfo: command not found

what can i do?
 
Old 05-26-2008, 11:45 PM   #8
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
I think you need mesa-tools... utils... something with mesa

For future questions - you might want to check the date of the thread you are replying to.
This one is 30 months old.
Plus the topics are not really related. You should start a new thread.

Last edited by oskar; 05-26-2008 at 11:46 PM.
 
Old 06-02-2008, 06:10 PM   #9
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Rep: Reputation: 31
oskar is talking about "mesa-7.0.2" i have the package installed and i get glxinfo responses but i could not tell you with absolute certainty that this package controls the command.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What is direct rendering and how to enable it. TruongAn Linux - Games 15 11-06-2005 12:31 PM
IM running Lycoris and I have the Game Pak how do I enable the Direct Rendering CaffeinatedGamer Linux - Newbie 14 05-31-2005 09:34 PM
change resolution + enable direct rendering ringmbr Linux - Hardware 0 05-20-2005 07:48 AM
Enable Direct Rendering rca36 Mandriva 12 03-29-2005 02:15 PM
how to enable direct rendering? marsques Slackware 2 09-07-2004 03:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration