LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   Half of my applications are broken. I am using Gentoo stage 1 on 3 nptl (stage 1.5) (https://www.linuxquestions.org/questions/linux-games-33/half-of-my-applications-are-broken-i-am-using-gentoo-stage-1-on-3-nptl-stage-1-5-a-308441/)

dragonslay 03-31-2005 11:01 PM

Half of my applications are broken. I am using Gentoo stage 1 on 3 nptl (stage 1.5)
 
Half of the applications in my gentoo installation seems to be broken, namely graphic applications.

Here is EVERYTHING broken:

Note: Just about everything here I used emerge with

-When trying to execute something compiled from g++ (as in you made it), it just says cannot execute, even when you enter the correct permissions (Compiler problems!?).

-When running games, most of them in one point of the application give you a segmentation fault.

-The command "wine regedit" gives
wine-pthread: stack smashing attack in function DrawFrameControl()
Aborted


-Many things wouldn't compile correctly, namely Mplayer. Usually giving something like We are not compatible with this version. I tried switching to a different compiler but it does nothing.

-Vmware would give the same kernal is not compatible with vmware even when you build the modules in.

-Countless other things that I forgot and I will post them here when I find them.

I will try to give many statistics about this installation as I can:

-I am using ext2 for my boot partition, reiserfs on my root, and, well, swap on my swap.
I also have a spare 4 gigs or so of free space when I feel like experementing with freebsd and such.

-Here is my make.conf:

# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O3 -march=pentium4 -mtune=pentium4 -fforce-addr -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
ACCEPT_KEYWORDS="x86"
PORTAGE_TMPDIR=/var/tmp
POSTDIR=/usr/portage
DISTDIR=${POSTDIR}/distfiles
PKGDIR=${POSTDIR}/packages
PORT4_LOGDIR=/var/log/portage
PORDIR_OVERLAY=/usr/local/portage
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
ALSA_CARDS="intel8x0"
RSYNC_RETRIES="3"
RSYNC_TIMEOUT=180
MAKEOPTS="-j2"
PORTAGE_NICENESS=3 (<-- just as a sidenote, I snorted when I saw that.)
AUTOCLEAN="yes"
FEATUERS="sandbox ccache distlocks"
CCACHE_SIZE="3G"
RSYNC_EXCLUDEFROM=/etc/portage/rysync_excludes
USE="acpi cups ithreads Idap nls nptl pam pthreads python readline samba ssl tcpd kde icewm gnome enlightenment cdr alsa esd libwww mpeg mp3 snmp sockets socks5 network dedicated network"

Kernal:
I do not know how to post statistics for this (as in what's compiled). If someone could tell me how that would be great.


Versions:
gcc: i686-pc-linux-gnu-3.4.3 20050110 *
Xorg: X11R6
Kernal linux-2.6.10-gentoo-r6
Stage tar: stage3-x86-2004.3.tar.bz2
Portage tar: portagemarch2005.tar.bz2 (yeah I changed the filename I think)

I am very aggrivated with this.

If anyone could help me out then I would a VERY happy man.

Thanks.

[edit] Ugh, crap, I accidentely posted this in the games section. Sorry mods, but please, could you move this to the software section? Thanks.

joeybravo 04-01-2005 06:11 AM

You will get better advice if you post your problem in
Gentoo forums. http://forums.gentoo.org

the command:

Code:

#emerge info
will provide more informative details.

Was it working before?
What did you do before you notice the errors?

Code:

CFLAGS="-O3 -march=pentium4 -mtune=pentium4 -fforce-addr -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe"
Implies your processor is Pentium4.

Godsmacker777 04-01-2005 11:53 AM

hey there,

The gentoo forums definitely rock. Personally, I post any gentoo related issues there (or join the irc channel), and general linux questions here.

In the past, there has been a bit of confusion over the proper way to update gentoo. I think this is the current and accpeted method. I run this set of commands each night and have had a solid system for awhile.

first sync portage, update all packages in "world", clean out broken dependencies, rebuild all broken dependencies and all is well.


[EDIT] You will need the gentool-kit for a few of these (depclean and revdep-rebuild), so emerge gentool-kit or something similar.

Code:

emerge sync
emerge -uDNvp world
emerge -uDNv world
emerge depclean -vp
emerge depclean -v
revdep-rebuild -vp
revdep-rebuild -v

Notice the set of flags for each command. the "p" is pretend, and will list out what would be done if run normally. i.e. emerge -uDNvp world will list out all of the packages that will be updated.

u = update
D = deep
N = newuse
v = verbose
p = pretend

check out portage's manpage for more info. I also run "glsa-check -f all" after all of that. glsa-check is a newer feature that is still marked "testing" though I haven't heard of one major problem with it yet. Glsa is the Gentoo Linux Security Announcements, and the command will update all packages that have resolved security bugs.

I was in your situation earlier this year and I did this to fix my system.

First, I opened my world file for reference (check portage's manpage for it's location). I unmerged all unwanted programs. then I ran:

Code:

emerge sync
emerge depclean -vp
emerge depclean -v
revdep-rebuild -vp
revdep-rebuild -v
emerge -uDNvp world
emerge -uDNv world
emerge depclean -vp
emerge depclean -v
revdep-rebuild -vp
revdep-rebuild -v
glsa-check -f all

I'm very happy. Good luck, and use your best judgement. Post to the forum, providing all of the info you think can help, or join #gentoo on irc.freenode.net for more info.

dragonslay 04-01-2005 06:23 PM

Quote:

Was it working before?
What did you do before you notice the errors?
I got the errors after I installed, well, sort of. The problem remained hidden until I tryed to emerge multimedia stuff.

Godsmacker, i'll try what you said. Thanks.


All times are GMT -5. The time now is 08:58 PM.