LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 05-05-2004, 10:31 PM   #1
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Rep: Reputation: 30
Half Life: Blue Shift w/ WineX Not Working


I can play the original half life just fine but Blue Shift doesn't work. It installs but it won't load. Anyone know anything I should try?
 
Old 05-06-2004, 03:11 AM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Does it come up with an error? Have you tried starting halflife then switching it to blueshift?
 
Old 05-06-2004, 03:47 AM   #3
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Have you tried starting the game from a terminal? What is the actual error you get when it crashes? It's hard to tell you what to do without knowing what's gone wrong in the first place.
 
Old 05-06-2004, 05:10 PM   #4
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
I can't load half-life first and switch to blue shift... it's a seperate application. Works that way in windows too. It doesn't come up with any error... im using Point2Play. How would I run it from a terminal?
 
Old 05-06-2004, 05:16 PM   #5
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
You would open a terminal, cd to the directory that the .exe is in, and then type winex3 (or whatever the command is to start winex is on your computer) blueshift.exe (or whatever the name of the game executable is).

so

winex3 blueshift.exe

Any error messages that WineX outputs will be printed in the terminal, and may give an indication of why the game won't start.
 
Old 05-06-2004, 05:44 PM   #6
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
nope... no error message... nothing. it did however pop up a box that said "Wrong Disc Inserted" when I didn't have my CD in but the I put the CD in and typed the command again and nothing happened.
 
Old 05-06-2004, 05:54 PM   #7
Jonny_Michaels
LQ Newbie
 
Registered: May 2004
Distribution: Mandrake9.1 kernel-2.4.21-0.13mdkcustom
Posts: 24

Rep: Reputation: 15
This sounds a bit familiar.

Its just possible that the game is running, but very, very slowly because your graphics hardware is not being used to accelerate it.

Does anything happen eventually?

The lack of error messages suggests its still churning away maybe.

Open a console and do

glxgears -info

This will show if your card is being used.

Hope this helps. =
 
Old 05-06-2004, 06:04 PM   #8
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
yea... that works. i know my graphics card is working properly because I have played Quake 3 and Unreal Tournament 2004. Also I have played half-life on WineX. I'm using the ATI Proprietery drivers. I set them up myself. Anyway this is that that command said:

GL_RENDERER = RADEON 9700 Generic
GL_VERSION = 1.3 (X4.3.0-3.7.6)
GL_VENDOR = ATI Technologies Inc.
GL_EXTENSIONS = GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_multisample GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_element_array GL_ATI_envmap_bumpmap GL_ATI_fragment_shader GL_ATI_map_object_buffer GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_ATI_vertex_array_object GL_ATI_vertex_attrib_array_object GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_ATIX_vertex_shader_output_point_size GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_EXT_vertex_shader GL_HP_occlusion_test GL_NV_texgen_reflection GL_NV_blend_square GL_NV_occlusion_query GL_NV_point_sprite GL_ARB_point_sprite GL_SGI_color_matrix GL_SGIS_texture_edge_clamp GL_SGIS_texture_border_clamp GL_SGIS_texture_lod GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SUN_multi_draw_arrays
11645 frames in 5.0 seconds = 2329.000 FPS
12613 frames in 5.0 seconds = 2522.600 FPS
12358 frames in 5.0 seconds = 2471.600 FPS
23489 frames in 5.0 seconds = 4697.800 FPS
29180 frames in 5.0 seconds = 5836.000 FPS
29134 frames in 5.0 seconds = 5826.800 FPS
28970 frames in 5.0 seconds = 5794.000 FPS
29152 frames in 5.0 seconds = 5830.400 FPS
29199 frames in 5.0 seconds = 5839.800 FPS
29361 frames in 5.0 seconds = 5872.200 FPS
29358 frames in 5.0 seconds = 5871.600 FPS
29097 frames in 5.0 seconds = 5819.400 FPS
29271 frames in 5.0 seconds = 5854.200 FPS
29148 frames in 5.0 seconds = 5829.600 FPS
29341 frames in 5.0 seconds = 5868.200 FPS
29443 frames in 5.0 seconds = 5888.600 FPS
29086 frames in 5.0 seconds = 5817.200 FPS
25192 frames in 5.0 seconds = 5038.400 FPS
28420 frames in 5.0 seconds = 5684.000 FPS
Broken pipe

It said broken pipe when i closed the windows with the gears spinning.
 
Old 05-06-2004, 06:06 PM   #9
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
Also I don't think it's still "churning away" because it brings up a new line in the terminal for me to type on a little while after I type the command.
 
Old 05-06-2004, 06:11 PM   #10
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Have you checked the Transgaming forums?
 
Old 05-06-2004, 06:13 PM   #11
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
yea... and good god they're slow. there's still a post from 2 YEARS AGO on there lol
 
Old 05-06-2004, 06:14 PM   #12
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
do you think it would have anything to do with the copy protection cause that's what i was kinda thinking
 
Old 05-06-2004, 09:15 PM   #13
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
What kernel are you using because supposedly kernel 2.6.x has a problem with copy protections. Are you mounting your blueshift cd first? Try downloading a crack for the game and running it.
 
Old 05-06-2004, 10:52 PM   #14
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
yea... im mounting it first. im using kernel 2.4.22-30mdk. ill try the crack thingy tommorow.
 
Old 05-07-2004, 04:44 PM   #15
AFI_Flame
Member
 
Registered: Apr 2004
Location: Nolensville, TN
Distribution: OpenSuse 10.2
Posts: 253

Original Poster
Rep: Reputation: 30
i can't find a crack for the latest version of the game
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Half Life frame per secon using WineX and Windows... ssobeht Linux - Games 13 01-15-2004 02:50 AM
Half-Life issues on WineX 3.1 Twiggy794 Linux - Games 5 10-22-2003 09:57 PM
WineX half-life install... b3nji Linux - Software 4 08-31-2003 03:37 PM
Problem with WinEx and Half-Life GPMatt Linux - Software 3 06-22-2003 03:48 AM
Low Performance in Half Life, winex and Slack9.0 tr4nce Slackware 1 04-18-2003 12:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration