Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Linux - Games This forum is for all discussion relating to gaming in Linux.


  Search this Thread
Old 07-07-2004, 12:16 AM   #1
LQ Newbie
Registered: Jul 2004
Distribution: Fedora Core 2
Posts: 5

Rep: Reputation: 0
Fedora core 2 + warcraft 3 + winex3 = Super lag Can any one help me fix this?

The title really says it all... I have a fresh install of FC2 this is my first time using Winex3 or any thing of the sort really. I have problems playing Warcraft 3 because it is soo laggy you cant do much of any thing. I wanted to know if there was a way I could fix this. I have a compaq (I know I should have gotten a Dell) 64 mb Geforce 2 XF, Half a gig of ram DDR, a 1.8 gig processor pentium III. Can any one direct me to a thread that already has this problem solved if it already has been? If you need any more specs just tell me.
Old 07-07-2004, 01:31 PM   #2
Registered: Aug 2002
Distribution: Debian
Posts: 540

Rep: Reputation: 32
What kind of lag? Lag when playing multiplayer? Or low fps? If it is low fps make sure you have direct rendering (glxinfo).
Old 07-07-2004, 06:28 PM   #3
LQ Newbie
Registered: Jul 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0
Well its really low fps. Well thank you I took a look and I found that I don't have direct rendering enabled... Could you or any one help me find out if I have it and where I can download it or enable it if I already have it.

Last edited by fourevilmonkies; 07-07-2004 at 06:40 PM.
Old 07-07-2004, 06:52 PM   #4
Senior Member
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Have you installed the nVidia drivers from the nVidia site? As far as I have heard, you need version 0.6106 to work with FC2.
Old 07-07-2004, 10:35 PM   #5
LQ Newbie
Registered: Jul 2004
Distribution: Fedora Core 2
Posts: 5

Original Poster
Rep: Reputation: 0

Now I have downloaded the Driver and am currently figureing out how to configure the xorg.config. Could any one give me pointers in this field.

Thanks for your help. I wuold have defenately not been able to do this without you guys and this awsome site... I managed to get my xorg configured and I have tested and it is all thumbs up...

Thanks again for your help.

Last edited by fourevilmonkies; 07-07-2004 at 11:25 PM.
Old 07-28-2004, 05:08 AM   #6
Registered: Oct 2003
Distribution: Ubuntu 7.04
Posts: 889
Blog Entries: 1

Rep: Reputation: 30
Well, heres my WHOLE HOW TO on instaling nvidia drivers, so u can make sure u did it right, and/or just show u my whole how to.
NOTE: Make sure u have ur kernel source installed.
1. Download drivers from
2. go into root. (I dont think it works by just typing su, I believe u NEED to be in root, its like u cant use lsmod when u "su")
3. Go into ur terminal, which is your START button - system tools - terminal, and type "init 3" .
4. cd into the directory where u downloaded the drivers (ie. /home/fourevilmonkies/)
5. type "sh ./NVID" then press tab to finish the rest.
6. When done, type "startx". And ur xserver should start.
7. go into a terminal, and type this. (I use gedit, it comes with gnome, kde comes with kwrite, just so u know) "#: gedit /etc/X11/xorg.conf" your config should pop up.
8. Scroll down to "section modules" and make sure Load "glx" is in ther, and make sure Load "GLcore" and "dri" are not. It should look like this....

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"

9. Then scroll down to section "device". And where it says drive change it so it says "nvidia" and not "nv" or "vesa". This should look something like this...

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 GTS (generic)"

Hope this helps.

PS: I dont know if u know how to do this or not, so forgive me if u think I thought u were an idiot at linux, I just dont know u. :]

For some reason--I get this I dont know about others-- when u change ur video resolution settings, or color depth, ur nvidia module BREAKS, and ur xorg.conf goes back to what it was before u edited it, and u might have to reinstall, if changing the driver back to nvidia FAILS. My suggestion is, if ur going to game alot, change ur color depth, and screen res, thats the section BELOW Section "Device" to how u want it to be. So u dont have to go throught the shi* I went to change my resolution, and color depth. PEACE! =D

Last edited by RHLinuxGUY; 07-28-2004 at 05:14 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
World of Warcraft, wine and Fedora Core 3 thanquol Linux - Games 5 02-03-2006 04:13 AM
Fedora Core 3 Installation CDs Fix? danielx Fedora - Installation 1 11-21-2004 10:27 PM
Fedora core 2 as a router and hosting warcraft 3 games? Glus Linux - Networking 1 08-13-2004 02:28 PM
fedora core 2 mysql wierd lag lqregislame Linux - Software 0 05-04-2004 01:16 PM
RPM lag fix by restart? GT_Onizuka Linux - Newbie 3 10-13-2003 04:22 PM > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration