LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 11-17-2005, 03:56 AM   #1
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Rep: Reputation: 30
Emulator (Cedega, Wine) on x86_64


I've searched and couldn't find one... can u point me to one?


Thanks./
 
Old 11-17-2005, 04:15 AM   #2
Que_273
Member
 
Registered: Nov 2005
Location: South coast
Distribution: Debian /AMD64
Posts: 48

Rep: Reputation: 15
Most emulators emulate 32 bit systems and so it does not make total sense to port them to 64 bit.
Many 64bit OS users keep a "chroot"ed 32bit system where 32bit apps (such as mozilla with flash & java plugins, openoffice) can be run with 32 libraries. WIne works fine for me there.
It is also possible to install parts of a 32bit system in the main tree (ie without the chroot) making sure ldconfig knows where the correct linkers and libraries are and that installed applications don't confict.
I'm a Debian user, so I'm sorry I don't know how easily this can be set up in either FC or Mandrake.
 
Old 11-17-2005, 04:18 AM   #3
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
blah,,,, is it possible to install 32 bit softwere RPM or whatever @ FC4 64 bit?

and how can I use chroot to help me here :S

omg
 
Old 11-17-2005, 04:40 AM   #4
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
when I write Cedega now
after I've installed it I think

it says

Code:
[zuki@localhost usr]$ cedega
Moving all local fonts to /home/zuki/.transgaming_global/Fonts and removing local Fonts directory
usage: cedega [-use-pthreads <yes/no>] [[-]-winver <version>] [[-]-debugmsg <debug>] [[-]-version] [[-]-use-dos-cwd <dir>] [[-]monitor-cdrom-eject] <application> [application parameters]

If you require additional help, please refer the HOWTO guide in the downloads section of the subscribers area.
How can I run a game with it?
:S
 
Old 11-17-2005, 05:11 AM   #5
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
OMG OMG OMG!!! I've managed to start C&C Generals

but... it's very laggish

laggish like I got no Graphic card at all :S

blahh
 
Old 11-17-2005, 06:30 AM   #6
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
I've installed Ati drivers but now, Generals sometimes loaded with lag and I have to exit and then I should reenter my username and password to login to linux
and sometimes writing the line with cedega ... generals.exe making me go to login screen again without doing a thing!.
 
Old 11-17-2005, 06:32 AM   #7
itz2000
Member
 
Registered: Jul 2005
Distribution: Fedora fc4, fc7, Mandrake 10.1, mandriva06, suse 9.1, Slackware 10.2, 11.0, 12.0,1,2 (Current)]
Posts: 732

Original Poster
Rep: Reputation: 30
Code:
[root@localhost ~]# cedega /mnt/win/Program\ Files/EA\ Games/Command\ Command and Conquer Generals/         Command & Conquer Generals Zero Hour/
[root@localhost ~]# cedega /mnt/win/Program\ Files/EA\ Games/Command\ and\ Conquer\ Generals/generals.exe
Created not existing system directory 'C:\My Documents'
tid 4448 received signal 2. Raising signal 3
tid 4456 received signal 2. Raising signal 3
/usr/bin/cedega: line 348:  4448 Quit                    $SHELL -c "$RUNWINE $WINVER -debugmsg $DEBUGMSG -use-dos-cwd $WORKDIR $EJECT $DT -- $COMMAND_LINE"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cedega on x86_64 quadfour Linux - Software 1 05-22-2006 04:12 AM
Netware Emulator Mars - Package marsnwe does not work in SuSE 10.0 x86_64 bagtel Linux - Networking 2 12-05-2005 09:37 AM
Netware Emulator marsnwe does not work in SuSE x86_64 bagtel SUSE / openSUSE 0 11-24-2005 04:24 AM
Wine, Cedega, Wine and Maple Story...getting close mwaddoups Linux - Games 9 11-23-2005 05:05 AM
How about a OS X emulator instead of WINE TikRu General 7 03-26-2002 10:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration