LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   cs 1.6 server protocol error (46) client (47) (https://www.linuxquestions.org/questions/linux-games-33/cs-1-6-server-protocol-error-46-client-47-a-170823/)

cillie 04-16-2004 03:39 AM

cs 1.6 server protocol error (46) client (47)
 
hi

i installed cstrike the 1120.bin...
and then when i wanted to connect to the cs server i got the error that my server aint running the same protocol version then my client

server running protocol (46)
client running protocol (47)

can someone help me please.

:scratch:

John5788 04-16-2004 05:19 AM

ur server is running cs 1.5 and your running cs 1.6(steam). either you connect to it in 1.5 or you use 1.6 server/

cillie 04-19-2004 04:00 AM

cs 1.6 server protocol error (46) client (47)
 
no

the server is definetly a 1.6 server.
tried connecting with 1.5 and doesnt work at all.
but the 1.6 gives the protocol error...

John5788 04-19-2004 07:44 PM

its saying server protocol 46. thats cs 1.5.... how did you setup ur cs server?

cillie 04-22-2004 04:52 AM

cs 1.6 server protocol error (46) client (47)
 
ok

I know now that i made a mistake.
the server is definetly a cstrike 1.5 server

how do i get it to 1.6? or to use protocol 47?

sorry about the mistake

reddog64 04-22-2004 05:54 AM

Follow this WORD FOR WORD!!!

http://server.counter-strike.net/for...threadid=30503

get lost?
email me i'll help...

nemesis@claneta.com

cillie 04-22-2004 06:30 AM

cs 1.6 server protocol error (46) client (47)
 
I dont know if i have to mension that i only use the server for lan's...

So can i only update the server if i do the update thru steam?

reddog64 04-22-2004 03:04 PM

yes, only way to update is through steam..
there is a NON STEAM copy of "steam" on the forum above...

just go into the cs steam linux support forum (same forum that article is in) and you'll see it it's stickied...

-Aaron

John5788 04-22-2004 07:33 PM

whats so bad about using steam? only thing i hate about it is the friends list. just set up steam for ur cs server. really easy and painless. took me about < 20 minutes to setup one under linux emulation on freebsd

cillie 04-23-2004 04:45 AM

cs 1.6 server protocol error (46) client (47)
 
ok

got steam working and downloaded czero,cstrike,valve and half life
so im on protocol 47 know and every things working :D

had to add a route thru putty and got the linux system connected to the internet and then created the account and started the update.

so everthings fine :p

reddog64 04-23-2004 07:28 AM

czero is still buggy in linux as a server.. so keep an eye on it...

oh and dont run it as root... :tisk:

have fun!

cillie 04-24-2004 04:33 AM

cs 1.6 server protocol error (46) client (47)
 
why cant i run czero as root?

icedude 12-29-2005 05:09 AM

Protocol 46 to 47
 
Hi

How did you manage to get your server to use protocol version 47.

I am using hlds version 3.1.1.1 and cstrike 1.5. I'ts running on protocol version 46. When i try to connect to the server it gives the error about the protocol version.


All times are GMT -5. The time now is 04:24 AM.