-   Linux - Games (
-   -   Can't get Age of Empires II: Age of Kings started (I've could it before !!!) (

vegetassj2 05-20-2005 02:40 PM

Can't get Age of Empires II: Age of Kings started (I've could it before !!!)

I have this game named Age of Kings
I was able to play it with wine before I installed my FC3 (I had FC 2 :p)
and now when I try it again in my FC 3 I get this weird stuff:

$ wine My\ Documents/Games/Age\ Of\ Empires\ II/empires2.exe
fixme:system:SystemParametersInfoW Unimplemented action: 110 (SPI_GETSHOWIMEUI)
fixme:ddraw:Main_DirectDraw_SetCooperativeLevel (0x77c58128)->(00010022,00000013)
fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 8
fixme:xrandr:X11DRV_XRandR_SetCurrentMode Cannot change screen BPP from 32 to 8
fixme:x11drv:X11DRV_DDHAL_CreatePalette stub
fixme:ddraw:Main_DirectDrawClipper_Initialize (0x77c58898)->(0x77c58134,0x00000000),stub!
fixme:ddraw:DIB_DirectDrawSurface_Blt dwFlags DDBLT_WAIT and/or DDBLT_ASYNC: can't handle right now.
fixme:system:SystemParametersInfoW Unimplemented action: 111 (SPI_SETSHOWIMEUI)

And it gives me an error message (bla bla bla make sure your Video card is compatible with DirectDraw)

Is there anyone who can help me?

thanks :)

ArbiterOne 05-20-2005 03:32 PM

Reinstall wine or rebuild it would be my suggestion. Things may have changed in FC3 that altered the way Wine works. Also, you might want to grab the newest version source or an RPM thereof, as it fixes many bugs.

vegetassj2 05-22-2005 03:11 AM


I had this version: wine-20050310-1fc3winehq.i686
I installed this version: wine-20050419-1fc3winehq.i686
and I'm still getting the same problem :(

akp913 06-17-2005 11:04 AM

vegetassj2, you said you got The Age of Kings to work with linux. Could you show me how you did so. Thx

vegetassj2 06-19-2005 05:45 AM

First I got it installed. Next I downloaded a no-cdcrack so it worked without CD.
$eject cdrom
$cd /were/you/installed/the/game
$wine empires2.exe

that's it :)

thiagoeliasr 06-23-2005 04:23 PM

I haven't tested AOE2 with Wine, but using Cedega, this game works with some screen glitches.. I don't know if some configs at configuration file can fix this problem.. I have to download wine and test it too..

well.. see ya..

(and sorry for my bad english language.. :p )

akp913 06-23-2005 04:54 PM

I got the game working, now all I need is the no-cd patch.

pescorilo 07-05-2005 12:51 PM

how did you did it?
I have the same problem using cedega 4.2.3 how did you solved this problem?

worldgnat 08-06-2005 03:03 AM

I'm running Lindows and I've tried wine. I also can't find the no cd crack. Any ideas where to find it? I'm so despirate that I saved the soundtrack with lsongs and I'm listening to it! Please help. Wine logged the error to /tmp/wine.log.BCnqjO, here it is:

fixme:vxd:VXD_Open Unknown/unsupported VxD L"sice.vxd". Try setting Windows version to 'nt40' or 'win31'.
fixme:vxd:VXD_Open Unknown/unsupported VxD L"siwvid.vxd". Try setting Windows version to 'nt40' or 'win31'.
fixme:vxd:VXD_Open Unknown/unsupported VxD L"ntice.vxd". Try setting Windows version to 'nt40' or 'win31'.
wine: Unhandled exception (thread 0009), starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 8 68") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

Does that help?


vegetassj2 08-06-2005 08:23 AM

The Game might work WITHOUT no-cd patch.
I had a few problems too but I red on a site you just need to wine 'empires2.exe' I tried and it worked.
But unfortunately now, using FC3, it doesn't.

I get the ' make sure your Video card is compatible with DirectDraw' problem over and over again :(

Any ideas:confused:

Cyblob 08-07-2005 10:20 AM

I had the same problem in the past. I'm not sure, but I think if you run the game from setup (from the CD, where it gives you the options to install, read help, play game ect..) and select play game from that screen then you are able to play it.

I've also found that reinstall AOE sometimes helps.

warrion_2000 08-09-2005 01:52 AM

When you used to play AoE 2 using Fedora Core 2, was it slow, and could you read the text? And secondly have you tried running the expansion ?

I've been going crazy trying to run AoE 2 on Linux. :)


vegetassj2 08-09-2005 03:50 AM

it worked perfectly except for the text at the bottom on the left (which I couldn't read very good)
and I WAS running the expansion

I read on a German site you just had to typ in a Terminal:
$ Wine /where/you/installed/the/game/empires2.exe

warrion_2000 08-09-2005 06:21 AM

Awesome. Can I suggest that you switch back to Fedora Core 2. AoE 2 is definitely worth it as you would well know ;)

Good Luck.

warrion_2000 08-09-2005 06:40 AM

Btw, I think before you think of going back to FC2 you can try and download the version of wine you had previously (in FC2) that might fix your problem. When you get a newer version of wine apps which worked previously may not work anymore.

All times are GMT -5. The time now is 02:52 AM.